Hello Guest it is June 17, 2019, 03:28:16 AM

Author Topic: Spindle DRO not working in Mach3 Turn  (Read 8725 times)

0 Members and 1 Guest are viewing this topic.

Offline MHJ

*
  •  18 18
    • View Profile
Re: Spindle DRO not working in Mach3 Turn
« Reply #21 on: September 24, 2010, 06:57:49 AM »
Hello.

I'm pleased to say that the brainboxes UC-146 for a second parallel port worked straight away. Costly, but effective and I can cope with that (just).

All I have to do now is get a full 10v out of the Homann Digispeed to get full revs on the spindle.......at the moment I can only get a maximum of 8.2v..

Thanks to all who have contributed and Mr. Simpson, if you're reading this, I will get one of those cards you mentioned and try it out. I've read a lot of your posts and it seems to me that you have successfully negotiated a number of steep learning curves!

Regards,
John.
Re: Spindle DRO not working in Mach3 Turn
« Reply #22 on: October 17, 2010, 05:02:54 PM »
I have a similar problem but for a different reason perhaps. I have a simple, single LPT set up with a home made breakout board and a single index pulse. With Mach3 R3.042.020 Turn, this works fine and I see a stable and accurate spindle speed from 50 to 2000rpm and I can thread well (given the known limitations of this version).

However, I updated to Mach3 R3.042.040 for the threading corrections and now I have no spindle speed in the DRO or in the Turn Diagnostics. Back to version 020 and its fine. I've tried to read up on this and read Rich's pdf but can't see where I've got it wrong.

I know there have been quite a few changes between vn 020 and vn 040, can anyone help me with why I would loose spindle speed? Is there a setting or approach I need to change to get this working? I can see the index pulse in diagnostics when I turn the spindle by hand but over 50rpm its gone. I've tried with turn diags enabled and without, which made no difference.

Is the new driver approach compatible with Win2000 and 1GHz P4 machine? Everything else seems fine and Mill works great as does my MPG with Turn and Mill at vn 040, just no Speed reading and presumably, no threading!

Thanks,

Woody.

Offline Hood

*
  •  25,843 25,843
  • Carnoustie, Scotland
    • View Profile
Re: Spindle DRO not working in Mach3 Turn
« Reply #23 on: October 17, 2010, 05:08:35 PM »
Have you got any Index Debounce set?
Also presume you are using Index and not Timing for the input?
You may need to also call aM3 or M4 if you are not already doing so.
Hood

Offline RICH

*
  • *
  •  7,337 7,337
    • View Profile
Re: Spindle DRO not working in Mach3 Turn
« Reply #24 on: October 17, 2010, 06:55:55 PM »
Quote
I've tried with turn diags enabled


The turn diagnostics should not be used in version .032 and above, so un-enable the plug-in.

Like Hood replied, you need to turn the spindle on as that tells  Mach to imeadiately start looking for the true rpm from an index pulse.
Make sure you do not have timing enabled. It dosen't work after .032 and is not better than a single index. The thread changes were implemented in 3.042.032 and .033 took care of a negative dro rpm  problem for computers with a fast bus speed.

I use 10 for  the index debounce and 600 for the interval. You may need to set yours to something different.

RICH