Hello Guest it is May 07, 2021, 09:19:43 AM

Author Topic: High Priority Under XP (anybody know for sure if it helps)  (Read 2971 times)

0 Members and 1 Guest are viewing this topic.

High Priority Under XP (anybody know for sure if it helps)
« on: August 11, 2010, 06:25:22 PM »
I have done a couple thing since, but this did seem to help yesterday before I made several other changes.  

Execute Mach 3 with High Priorty instead of Normal Priority under Windows XP.  

With Mach 3 running:
You can open the task manager right click Mach 3 and select go to process.  Then right click the process and select prioty then high.  I was cautioned against selecting real time as it may take over the system resources to the point it may be slow or even fail to accept input from devices like the keyboard.  

To load Mach 3 with High Priority Automatically:
Right click the shortcut you use to Mach 3 and select properties.  In the Target field insert "cmd.exe /c start /high " infront of the rest of what you already have in that field.  

Now I plan to run Mach this way for a while to see how it performs, but I also just did a successful downgrade from SP3 to SP2 which I was told ran Mach 3 better with fewer problems.  I actually had an old copy of SP1 that I no longer have installed on any working computers.  Then I downloaded SP2 and upgraded, so don't go asking me about any magic tricks for downgrading.  I'ld have to Google it just like you would.  

If I still can't run 80K lines of code without a major walkabout in the wrong direction I'll be putting a non-integrated video card in next. 
« Last Edit: August 11, 2010, 06:30:31 PM by Bob La Londe »

Offline budman68

*
  • *
  •  2,354 2,354
    • View Profile
Re: High Priority Under XP (anybody know for sure if it helps)
« Reply #1 on: August 11, 2010, 07:02:47 PM »
Forgive me Bob, I saw you were having some trouble with the G540 (I can't remember where I saw your post) but did you try disabling ACPI in the Bios, and select "EPP" for the parallel port in the Bios of the PC?

Dave
----------------------------------------------------------------------
Just because I'm a Global Moderator, don't assume that I know anything !

Dave->    ;)
Re: High Priority Under XP (anybody know for sure if it helps)
« Reply #2 on: August 11, 2010, 07:11:25 PM »
I do have the LPT port set as EPP.  Not sure what ACPI is, but I will look. 

Offline budman68

*
  • *
  •  2,354 2,354
    • View Profile
Re: High Priority Under XP (anybody know for sure if it helps)
« Reply #3 on: August 11, 2010, 07:16:42 PM »
Bob, here's some very helpful reading as it helped me a LOT.

http://www.machsupport.com/downloads/XP_Optimization.txt

Dave
----------------------------------------------------------------------
Just because I'm a Global Moderator, don't assume that I know anything !

Dave->    ;)