Hello Guest it is July 19, 2019, 01:19:47 PM

Author Topic: How to setup MACH3 for dual parallel port  (Read 2540 times)

0 Members and 1 Guest are viewing this topic.

How to setup MACH3 for dual parallel port
« on: October 09, 2016, 02:56:28 PM »
Hi - I'm new to CNC and could use some help getting this machine going.

My specific question is - connecting PC parallel ports from PC to machine - does it matter which one is connected where?  Or just connect them and then configure in MACH3 settings?

The machine is a Light Machines 2000 and it was previously retrofitted with Gecko G320X-DC drivers, a Sound Logic BOB, and Mach3 that was connected from PC to machine by 2 parallel ports and all was good per PO.  The did not have the PC at the time i purchased.

I have build a PC, installed MACH3, the PC has one parallel port on the mainboard IO panel and it has a second parallel port on the PCI parallel port adapter card  (that was on the previous PC that ran this machine). I am running on Windows XP.

I have read the MACH3 manual where it states 2 parallel ports can be used, but there is no documentation on connecting parallel ports to the BOB or other interface or which parallel port to use for which - or does it matter.  The first parallel port in the pictures goes to the pendant, the other two are the 50/50 guess.


Can anyone point me in the right direction big picture of things i may need to think about, perhaps advice on connecting the parallel ports or if there is a good thread or tutorial to shed light on this.

Thx,

Paul G
« Last Edit: October 09, 2016, 03:14:51 PM by Paul G »

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: How to setup MACH3 for dual parallel port
« Reply #1 on: October 09, 2016, 04:13:33 PM »
All you have to do is set the address in Ports and Pins main page for ports 1 and 2 then you can configure whatever you want.
You can also set port 2 to have pins 2-9 as inputs rather than the normal outputs if you want but some parallel ports don't allow that.
Then when configuring things such as axes or limits or whatever you just have to tell Mach whether it is port 1 or 2 and pin number that they are connected to when you are setting them up.


Hood
Re: How to setup MACH3 for dual parallel port
« Reply #2 on: October 10, 2016, 01:29:44 AM »
Thanks.

I'll look into this.  Is there a standard pin configuration that is commonly used for pin assignments - i.e. most MACH3 has default settings and most people would just use those when setting it up?

thx,

Paul G

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: How to setup MACH3 for dual parallel port
« Reply #3 on: October 10, 2016, 03:07:05 AM »
Not really, just as long as you know which pins are outputs and which are inputs. On port 1 they are fixed, port 2 as previously said you can configure 2-9 as inputs if you require more inputs than outputs. Just to make clear, if you do enable the option for Port 2 to have 2-9 as Inputs then it is all of them that become Inputs, you can't choose to have 2 and 3 as Inputs and keep 4-9 as outputs.

The only other thing to consider is some breakout boards may need a certain pin to be used for the E-Stop often pin 10 but other than that you can just do as you wish.

Hood
Re: How to setup MACH3 for dual parallel port
« Reply #4 on: October 31, 2016, 12:18:54 AM »
Can anyone set me straight on how to set up PWM spindle control in MACH3.

Ok - i have axis moving now with keyboard manual control and via MACH3 commands :), and Estop enabled.  I think i have the charge pump working (not quite sure).

Next is the spindle control.  Question is how to set it up properly in MACH3?
Machine config:
HW wise -  it should be all setup correctly (well meaning it worked for previous MACH3 XML that i don't have access to):
  -BOB is sound logic -PC2 Rev 3.
  -PDMX-106 spindle controller - is PWM, and i suspect relay for direction control.

  -PDMX instructs to use Output Pin 14 for direction and Pin 16 for PWM.

  -I've read the MACH 3 manual and from that - am totally confused.

  -I have enabled the spindle in "ports and pins/axis" with pin 14/16. and enabled PWM in the "ports and pins/spindle setup".[/left][/pre][/left][/center][/left]

Can anyone set me straight on how to set this up in MACH3.