Hello Guest it is December 10, 2019, 04:50:11 PM

Author Topic: scripter compile error , In:  (Read 4565 times)

0 Members and 1 Guest are viewing this topic.

scripter compile error , In:
« on: July 26, 2010, 12:28:55 AM »

scripter compile error , In:

This the message I get when I want to activate any button (wc offset, tooling, run user exts, setting, hardware and refenre)

What is the problem ?

Thank you
Re: scripter compile error , In:
« Reply #1 on: July 26, 2010, 02:35:14 AM »
What revision of Mach are you using?
Dave
Author of the MachStdMill Extensions for Mach3
www.CalypsoVentures.com
Re: scripter compile error , In:
« Reply #2 on: July 26, 2010, 09:24:44 AM »
In the beginning I had 3.042.040, I was thinking this was the last version.

So when I have realized my error, I have downloaded 3.043.011

After that It was impossible to open Mach 3 with Machstdmill . I got the message my version was not correct.

I make a lot of try, uninstall mach3 3.042.040 and 3.043.11. Re-install 3.043.011 and re-install Machstdmill. I always got the same message, my version is too older

Re: scripter compile error , In:
« Reply #3 on: July 26, 2010, 11:02:11 AM »
My apologies,
You are the victim of an unfortunate combination of events.

1) MachStdMill requires a minimum Mach3 version of 3.43.10.
That is why nothing works in MSM when running 3.42.40. There is no way for MSM to tell you this as when it installed on top of versions < 3.43.10 - because the MSM code that checks the mach version is never run by earlier versions of Mach3 (they do not have the interfaces used by MSM).

I realize you figured this out....

2) Unfortunately, at the same time you were doing this over the weekend, Brian replaced 3.43.10 with 3.43.11.
That would have been fine except that 3.43.11. was a bad mach version and it reported it's version to MSM as 0.0.0 - which MSM figured was just a just a bit to old .... and so MSM refused to run with it....

I just noticed that Brian has now posted 3.43.12.
I have not personally had a chance to try 3.43.12 yet.

I have also asked Scott to make 3.43.10 available from the download archive page so that people can get that version in case something like this happens again in the future.

Dave
Author of the MachStdMill Extensions for Mach3
www.CalypsoVentures.com
Re: scripter compile error , In:
« Reply #4 on: July 26, 2010, 11:22:17 AM »
What is the things to do ?

Just dowload the new release ?


Thanks you
Re: scripter compile error , In:
« Reply #5 on: July 26, 2010, 11:48:51 AM »
As I write this there are two choices:
1) download Mach 3.43.12 and use it
or
2) download Mach 3.43.10 and use it.

<edited 7-26-2010 8:52 PDT - 3.43.10 is not available also>

Dave
 
« Last Edit: July 26, 2010, 11:52:30 AM by DaveCVI »
Author of the MachStdMill Extensions for Mach3
www.CalypsoVentures.com