Hello Guest it is December 06, 2019, 07:02:29 PM

Author Topic: X axis looses orintation  (Read 3368 times)

0 Members and 1 Guest are viewing this topic.

X axis looses orintation
« on: October 19, 2010, 12:38:39 PM »
Hi. All
       My KX1 running under Mach3 has been trouble free for a long time now, although I'm using it a lot.   Currently I'm machining a gear case and cover plate with identical profiles.    I've cut the gear case using a sub routine in incremental steps to a depth of       Z-10mm with no problems.    To machine the cover plate the only changes I made to the programme was to change the z depth to Z  -3.3     Half way through the first cut of the profile the cutter wandered off into the middle of the plate.    After feed hold, stop and rewind I returned the spindle to absolute zero, where the spindle came to rest roughly 12mm in the plus quadrent, with all the axis windows reading zero.     Any ideas where to start looking?

Offline kf2qd

*
  •  123 123
    • View Profile
Re: X axis looses orintation
« Reply #1 on: October 25, 2010, 04:37:28 PM »
Did you use G42 for your first part and G41 for your second part? G41 "sometimes" has issues and the Mach folks are aware of the problem.

You also might want to look at Config/Motor Tuning and look at the step pulse for each axis. This should affect things the same all the time, but ... They say it should be some value between 1 & 5 but my machine seems to like 6. If it is too low you may miss a step or steps.


Di the motors sound different during the time when the motin did not follow the path? that is the first sign that you are either missing steps or overloading the motor.
Re: X axis looses orintation
« Reply #2 on: October 26, 2010, 04:38:45 AM »
Hi.
    I had a reply from machsupport, who were saying the same thing about loosing steps, I'm away from the machine for a few days, but will definitely investigate when I get back, thanks for replying.