Hello Guest it is July 21, 2019, 07:32:51 AM

Author Topic: 3D acceleration problems and choppy cuts  (Read 8351 times)

0 Members and 1 Guest are viewing this topic.

Offline simpson36

*
  •  1,374 1,374
    • View Profile
Re: 3D acceleration problems and choppy cuts
« Reply #10 on: June 23, 2010, 06:48:52 AM »
The 3D nature of the part more than likely requires the segmented line approach. On the other hand, even arcs ultimately are segmented lines, albeit very small ones. If you are running say 1000 steps per inch, a .001" segment is as small as the machine can physically resolve. Moreover, there is no point in using a line segment much smaller then the tooth load, so for example it is physically possible for a .005" segment to produce an arc that is effectively as smooth as with a .001" segment.

In the OP's case, the segments are an order of magnitude too large, and I have to agree that this will be visible even with a high accelleration. Generating G-code with smaller segments should cure that, but loosing position is a separate and far more serious problem, methinks.

Here is a link a similar power supply.  Spec is slightly different, but the info is similar and the link works.

http://www.antekinc.com/details.php?p=342

Offline simpson36

*
  •  1,374 1,374
    • View Profile
Re: 3D acceleration problems and choppy cuts
« Reply #11 on: June 23, 2010, 06:56:46 AM »
For comparison sake, here is a tiny chunk of the code for rotary engraving a fairy character, and the video showing the cut (done with a pen only). Cutting starts 40 seconds into the video. Note the size of the segments in the code and the smoothness of the resulting curves on the workpiece.

http://www.youtube.com/watch?v=sC2urdg_bqg

G01 A-1.2137 X-1.8734
G01 A-1.2185 X-1.8782
G01 A-1.2235 X-1.8829
G01 A-1.2283 X-1.8871
G01 A-1.2331 X-1.8908
G01 A-1.2375 X-1.8941
G01 A-1.2420 X-1.8972
G01 A-1.2465 X-1.8997
G01 A-1.2507 X-1.9020
G01 A-1.2552 X-1.9039
G01 A-1.2591 X-1.9056
G01 A-1.2633 X-1.9067
G01 A-1.2675 X-1.9076
G01 A-1.2714 X-1.9081
G01 A-1.2754 X-1.9084
G01 A-1.2793 X-1.9084
G01 A-1.2832 X-1.9081
G01 A-1.2868 X-1.9076
G01 A-1.2908 X-1.9067
G01 A-1.2983 X-1.9039
G01 A-1.3056 X-1.9006
G01 A-1.3132 X-1.8961
G01 A-1.3207 X-1.8905
G01 A-1.3283 X-1.8843
G01 A-1.3361 X-1.8776
G01 A-1.3440 X-1.8697
G01 A-1.3479 X-1.8658
G01 A-1.3490 X-1.8647
G01 A-1.3496 X-1.8641
G01 A-1.3499 X-1.8641
G01 A-1.3513 X-1.8647
G01 A-1.3566 X-1.8667
G01 A-1.3619 X-1.8689
G01 A-1.3734 X-1.8734
G01 A-1.3852 X-1.8773
G01 A-1.3908 X-1.8790
G01 A-1.3966 X-1.8804
G01 A-1.4022 X-1.8812
G01 A-1.4076 X-1.8812
G01 A-1.4126 X-1.8810
G01 A-1.4176 X-1.8798
G01 A-1.4221 X-1.8776
G01 A-1.4244 X-1.8762
« Last Edit: June 23, 2010, 06:58:33 AM by simpson36 »

Offline derek

*
  •  201 201
    • View Profile
Re: 3D acceleration problems and choppy cuts
« Reply #12 on: June 23, 2010, 02:48:37 PM »
First of all Thanks for trying to help me on this.

I didn't reply specifically to the other posts as I think I cover them in this post and will cover them by the end of the tests.


I'm trying to keep forward momentum on this pattern while I'm trying to fix the chopping.

Here is a screen shot of what I'm carving

It's 24” in diameter and 10” deep. I'm carving the interior.
 I was waiting for some material to dry so I did a few tests. I set the acceleration to 30 on the X and Y and ran my roughing file with no cutter. It's a horizontal strategy with a .125” step. I set up a dial indicator on the Y axis and relied on the optical sensor on the X. After running the file the Y axis was off by .015”.  I reset the axis and ran the file again but stopped it before it got to the boss at the bottom. It was right on the money. I continued to finish the run and it was off by .010.  When the bit approaches the boss and makes the sudden change in direction it is quite violent. I believe this is what is causing to loose position.  I don't think it's mechanical as the toothed pulleys are keyed to the shafts. I then set the acceleration back to 12 and ran the file again. It came right back to "0" on the dial indicator.

I plan on doing a few tests on the finish cut on this pattern. 

Test 1. cut 1.5" with the same strategy as I used on the other pieces. this will be choppy.

Test 2. Increase the acceleration to 30 and cut another 1.5"

Test 3 convert lines to arcs and cut anther 1.5"

Test 4 reduce acceleration and cut another 1.5" with arcs. 

At this point I'll probably finish off the pattern as I'm starting to fall behind. Hopefully it will be a good visual as to what's going on.

I'll be doing this tomorrow.

Thanks again
Derek

Offline derek

*
  •  201 201
    • View Profile
Re: 3D acceleration problems and choppy cuts
« Reply #13 on: July 14, 2010, 07:32:41 PM »
Here's an update for anyone that's following this. I finally got some time to go through the  mechanics and electronics. I had a bunch of stuff to take care of on this thing that I've been putting off so I jumped right in. The bottom line is the ball screw nut on the Y axis came loose from the flange. I had rebuilt the entire Y axis a few months ago and forgot to put lock tight on the threads. Big head slap moment. That would explain why it would loose more with higher acceleration.
I just figured that out at quitting time so I didn't have time to do a proper test but the quick one I did do came out dead nuts on.
I'm still going to replace the servos and drives with something more robust. I ordered three Dugong drives and their HDBB breakout board. I'm going to change out the servos to the 1125 oz models.

When I get that all set up then I'll attack the chopping issue again. Maybe it will be gone!

Thanks again everyone for all the help.

Derek

Offline Sam

*
  • *
  •  988 988
    • View Profile
    • hillbillyhilton.com
Re: 3D acceleration problems and choppy cuts
« Reply #14 on: July 14, 2010, 07:51:45 PM »
Glad to hear you got it sorted!
"CONFIDENCE: it's the feeling you experience before you fully understand the situation."