Hello Guest it is November 29, 2022, 07:26:04 PM

Author Topic: Possible Soft Limit Bug  (Read 2492 times)

0 Members and 1 Guest are viewing this topic.

Possible Soft Limit Bug
« on: May 10, 2010, 09:44:47 PM »
I found an issue with Soft Limits in Mach3 Mill, I'm posting here to let Artsoft know about the behaviour I have seen.  No great urgency in addressing it, since I'm aware of it now, and no one else seems to be speaking up about having the same issues.

Following text is cross posted from my post at CNCZone: http://www.cnczone.com/forums/showthread.php?t=104676

I've come across what I suspect to be a bug in Mach3, but would really like to get some other people to try it out or let me know if I'm doing something wrong.

When I program a move on the MDI screen that has a target outside the soft limits, the machine drives to the soft limit and stops, then program a move away from that position, the motor stalls - it may or may not break free and move again by itself, steps have obviously been lost though.

In contrast, if I hold shift to override the jog setting and drive the table against the soft limit, and back off again, all is fine.
It all seems so bizzare that the behaviour is different. I can't imagine any physical difference between a manual jog rapid against the soft limit and a programmed rapid against the soft limit.

I've observed this on my Y axis, and haven't looked at X.
We have our soft limits set very close to the physical end stops, so we spent a bit of time loosening off the gib screws and concerned about it actually hitting the hard stops and binding there.

I have tried setting the soft limit on the other end of the Y axis well inside the normal setting. And seen the same behaviour.

Our mill is a Syil X4 Standard.
Really only been running it since February this year.
I haven't looked at changing the motor settings yet, and I'd prefer not to at this stage, since it's previously been okay with the defaults from Syil. I don't think we've had a program that has ever tried to drive outside the Y travel limits.

Running Mach3 Ver 3.42.029
I don't see anything like this listed in the change log since.

If anyone can have a look and replicate the behaviour, or otherwise have some feedback for me, that would be great.

- Ian.

 Obviously, intentionally driving the machine against soft or hard stops is 'doing something wrong', so I've stopped doing that for now.

I've observed the same stall behaviour on the X axis, with soft limits set inside what they usually are.

I'm going to leave Z well alone.

Though I haven't checked with a loaded program, just running commands on the MDI.

So long as we don't create any programs that are too large, or setups too offset, and take note of the soft limits warning, then we shouldn't have a problem.

I'll just have to be a bit more careful about my edge-finding then offsetting to part-zero method.

- Ian.