Hello Guest it is September 19, 2020, 03:49:23 PM

Author Topic: Threading no go?  (Read 5733 times)

0 Members and 1 Guest are viewing this topic.

Threading no go?
« on: March 29, 2010, 06:56:34 AM »
Hi all

So I got my lathe setup all working fine. No problems at all under normal operation.

So I thought I'd try some threading. Connected up the index wire to pin 15 and I am getting a stable accurate reading -500 rpm.
Is it normal that it's -500 and not just 500?

The spindle is externally controlled but I have fiddled with setting it as relay controlled.

Anyway when it comes to threading the machine moves to position then just waits there forever. I have used the Threading wizard to create a g76 command and I've hand typed it. I've fiddled with spindle settings and well all settings but cannot get anything to happen on a g76 command either onscreen or on the machine with an index connected.

I'm using Version R3.042.032 if I disconnect the machine completely and just run the program then the program will cycle through correctly.

Thanks Rufe0

Offline RICH

*
  • *
  •  7,412 7,412
    • View Profile
Re: Threading no go?
« Reply #1 on: March 29, 2010, 08:29:42 AM »
RUFE,
Take a look at the Threading on The Lathe Manual - Mach 3 Turn which can be found in the Members Docs.
- sect 3.5 - Trigger Test
- sect 7.0 - Configuration
You should have a positive rpm . The rpm is based on the index pulse and so is the triggering to start the threading.
RICH
Re: Threading no go?
« Reply #2 on: March 29, 2010, 11:01:15 AM »
fixed it details to follow

Offline RICH

*
  • *
  •  7,412 7,412
    • View Profile
Re: Threading no go?
« Reply #3 on: March 29, 2010, 05:43:25 PM »
Glad you got it working.  :)
By all means post what you did for the benefit of others.
RICH
Re: Threading no go?
« Reply #4 on: March 30, 2010, 05:43:36 AM »
Deselecting Use Spindle Feedback in Sync Modes fixed it. Did a couple threads successfully. My machines maximum traverse speed is only 150mm/min so doing threads at 500rpm is pretty much out of the question, going to have to slow that spindle down some...

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: Threading no go?
« Reply #5 on: March 30, 2010, 05:51:07 AM »
As far as I am aware you need that selected for proper threading. You may be getting lucky by getting a reasonable looking thread with it unselected but I dont think its the correct thing to do.
Hood
Re: Threading no go?
« Reply #6 on: March 30, 2010, 06:42:37 AM »
you might be right hood, the first one i did was ok but the second one i tried was horrible however I had spindle trouble
Re: Threading no go?
« Reply #7 on: March 30, 2010, 07:04:32 AM »
What would cause a negative spindle speed vs a positive?

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: Threading no go?
« Reply #8 on: March 30, 2010, 07:54:36 AM »
Dont know, can you attach your xml and I will have a look. One thing is definitely make sure you dont have the threading diagnostic plugin enabled if you are using one of the latest revisions of Mach as that will screw things up.
Hood

Offline RICH

*
  • *
  •  7,412 7,412
    • View Profile
Re: Threading no go?
« Reply #9 on: March 30, 2010, 11:04:03 AM »
Quote
What would cause a negative spindle speed vs a positive?

Did so many tests that i don't recall exactly,but i am thinking you have the threading plug-in enabled.
If the plug in is enabled the rpm is not true since it's then pc based, so as Hood said it realy screws things up.

You need to have the Use Spindle Feedback in Sync Modes checked as that controls how the feed rate will be adjusted during the actual threading  (ie. it will slow down or increase the feed based on the TRUE rpm). Otherwise all the controls built into the threading cycle are not not being utilized ( sort of like taking the plane out of auto pilot and your flying in a storm and can't see )!

Which leads me to ask or say,
Are you making note of the calculated feedrate to specified rpm for  the thread in the wizard?
At 150mm/ min ( approx 6 in/min) your max rpm would be around 100 rpm for say 20 tpi. If your running 500 rpm instead of the 100
then the program adjusts the feed rate down /  not up as it can't so the first cut may be all right but the next would be trashed.
And you should not run at you max feedrate since your are loosing torque and may run into other problems.

I would suggest that the configuration be correct ( so post your XML ),  that you check the index, then check the rpm, then do a scribe test, then do some testing of threading to see how "your" lathe system works at different cut depths.

Post your XML as Hood has asked and we can start from there.
RICH