Hello Guest it is June 06, 2023, 07:49:16 PM

Author Topic: no spindle feedback  (Read 3321 times)

0 Members and 1 Guest are viewing this topic.

no spindle feedback
« on: March 21, 2010, 01:14:42 PM »
Hi all hope someone can help me
have been running mach3 turn screw cutting most days for about 9 months has been perfect no problems
I updated mach 3 with the latest version and now have no recognition of the spindle rpm
have  put the old version of mach3 back in still the same
deleted mach3 and reloaded I now have it reading the rpm exactly
but on running my program get fault (no spindle feed back on G95)
have even tried my main computer in the workshop but as that was the one that I downloaded the new version on same problem
would really appreciate some help
many thanks

Offline Hood

  •  25,835 25,835
  • Carnoustie, Scotland
    • View Profile
Re: no spindle feedback
« Reply #1 on: March 21, 2010, 01:38:04 PM »
Few things changed in recent versions with regards spindle feedback. First is the timing input is no use, you need to use the Index input, so if you were previously using timing you will either have to use an old version or change your input to a single pulse per rev.
Another thing is make sure you do not have the threading diagnostic plugin active.
Last thing I can think of is you need to have the disable spindle relay box unchecked.
If non of these help attach your xml and I will see if I can find a problem.

Re: no spindle feedback
« Reply #2 on: March 28, 2010, 12:54:16 PM »
many thanks for your prompt reply hood
tried every thing but still the same
reloaded the old version again
it read the rpm but not on the program
then found it had lost my licence somehow
reloaded the licence
now every thing has returned to being a brilliant program
again thank you for your offer
I have just finished converting the mill and am trying to get to grips with mill programe so sure as hell will need some help in the future,
wish there was a mach3 for dummies
thank you