Hello Guest it is May 12, 2021, 11:25:43 AM

Author Topic: leaving toolpath and crashing into material  (Read 3260 times)

0 Members and 1 Guest are viewing this topic.

Offline xaco

*
  •  26 26
    • View Profile
leaving toolpath and crashing into material
« on: March 15, 2010, 12:56:02 PM »
hello everyone, i use mach3 on my small cnc,and it happened to me yesterday that my tool sudenly left toolpath and crashed into material....it was performing a paralel finnish milling along y  making a 1x1 inch piece (minus part of a stamping die ) in plexy and going back and forth,bit down  and again back forth along y,and in 1 line  while taking just a fin layer on the top and coming to "end of stock" he ,insted of turning back like 100 times before,the tool just continued  to go straight and after half of inch went deep into material and stoped,"zero" of corse changed to somwhere on that sot where it "landed" .i dont know if zero changed b4 or after.but i didnt notice mistake in g-code cos i took tool out and put it back and this time he did corect his path.. anyone  experienced this?                                                                      Miro

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: leaving toolpath and crashing into material
« Reply #1 on: March 15, 2010, 04:11:14 PM »
Sounds like possibly an axis stalled. Did you notice if the toolpath and DROs  showed this wrong move?
Hood

Offline xaco

*
  •  26 26
    • View Profile
Re: leaving toolpath and crashing into material
« Reply #2 on: March 15, 2010, 05:21:45 PM »
hm,i cant remember what mach toolpath shown but i think taht  all the time on toolpath display it was shown toolpath with all lines ,blue 1, and paralel to that  green toolpath that tool just passes,but those two were not  one  on other matching like it should be but 1 next to other,pretty far from eachother.....but i am sure taht at the begining toolpath didnt show that move cos it went totaly out of 1x1 inch square toolpath...

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: leaving toolpath and crashing into material
« Reply #3 on: March 15, 2010, 05:29:06 PM »
If it happens again have a look and see if the DROs show where the tool is or if they still show where it should be.
Hood

Offline RICH

*
  • *
  •  7,419 7,419
    • View Profile
Re: leaving toolpath and crashing into material
« Reply #4 on: March 15, 2010, 05:43:33 PM »
The only time the mill ( steppers ) here went on it's merry way and cut through something was due to missed steps.
You will here it when it happens.
It my case it was caused by having the velocity / acceleration set to high and not leaving any headroom for the machining.
So now run rather conservatively at about 30 to 40 % below max velocity and have never seen it happen since.
RICH

Offline xaco

*
  •  26 26
    • View Profile
Re: leaving toolpath and crashing into material
« Reply #5 on: March 15, 2010, 06:00:59 PM »
i think my cnc is set on 700mm/min,and i was running on 70 to 100mm/min...and he was cleaning 0.1mm of surface on 1x1 inch piece and just continued straight  for next 1/2 inch and sloped down  like a shovel.......i dont think he missed any step before......guy that made my cnc told me that mach sometimes just does smthing strange...