Hello Guest it is October 15, 2019, 11:02:35 PM

Author Topic: Scale is off..  (Read 2545 times)

0 Members and 1 Guest are viewing this topic.

Scale is off..
« on: February 20, 2010, 08:32:42 PM »
I've done a search and read about a zillion replies, and still don't see any suggestions for anything I haven't already  done. I'm stumped. When I run the roadrunner g-code, the tool path on the display moves much faster than the actual x/y/z's are moving. The  DRO scale is 1.
Steps Per Math is...
 200 steps per rev on the motors
 1/4 - 20 lead screws,
 1/8 micro stepping,
 "Steps per" is 32000  Right??

I have verified the board (Rockcliff) is set to 1/8 microstepping from the factory, and I have double checked the jumpers myself. No jumpers on = 1/8 microstepping.  I'm also thinking if the board was not microstepping, and I had Mach configured at 32000, it would have the opposite effect correct? Motors are tuned down to 20 inches /min velocity as the default setting of 40 was too fast for them. 

The difference in the scale is substancial, in fact it may be 1 to 8 ???
I swear I don't have steps per at 320,000.
What else could it be ??
Going nuts in Texas...
Re: Scale is off..
« Reply #1 on: February 21, 2010, 12:44:36 AM »
Curmudgeon,

I am a little confused by your description of your problem, hence my question:

On the MDI screen, if you command an axis move of x inches (for instance, type G0 X6 in the Input box), how far does your axis actually move?

If your X axis does not move 6 inches, then you have a configuration setup problem.

If it does move 6 inches, repeat the test with the Y  and Z axis.

Regards,
John Champlain

Offline Chaoticone

*
  • *
  •  5,607 5,607
  • Precision Chaos
    • View Profile
Re: Scale is off..
« Reply #2 on: February 21, 2010, 07:43:53 AM »
Sound advise, thanks John.

Brett
;D If you could see the things I have in my head, you would be laughing too. ;D

My guard dog is not what you need to worry about!
Re: Scale is off..
« Reply #3 on: February 21, 2010, 06:03:56 PM »
The problem was with the PC. The configuration is fine. I have a PC upstairs I have been uising for all the  softeware testing. Saturday I got the motors installed on the CNC I built, and so I had to transfer everything to a different PC dedicated to the new CNC. A notebook actually. I knew the notebook would cause problems at some point, but based on what I had read I was expecting lock ups and errors of that type, not problems just running a stepper. I ran the driver test on the PC and on the notebook. While the test on the notebook said the pulse rate was steady, the graph indicated a serious problem and was actualy clipping at both ranges. I had planned to use a Smooth Stepper from the begining, but wanted to get the CNC  running right with the parallel interface first to make sure any problems I had, I could isolate to the origianl configurations, or the Smooth Stepper. I went ahead and installed the SS and configured Mach3 for it and it's all running fine now. In fact, it's running much smoother and much faster than with the parallel driver and the full size PC.
Sorry about yelling "Wolf" but I'm new to this and didn't know what a well tunned stepper sounded like. I think with the notebook it was just getting a small fraction of the pulses and hence the apperance of a scaling issue.
Learning as I go....

RE
 
« Last Edit: February 21, 2010, 06:05:28 PM by Curmudgeon »