Hello Guest it is October 19, 2019, 11:49:02 AM

Author Topic: Mach 3 Slave Axis problems.  (Read 18961 times)

0 Members and 1 Guest are viewing this topic.

Offline Hood

*
  •  25,855 25,855
  • Carnoustie, Scotland
    • View Profile
Re: Mach 3 Slave Axis problems.
« Reply #10 on: February 18, 2010, 07:50:16 PM »
Thats not good :(  Is it an early revision as the site suggests that they can be easily removed. Have you swapped pin assignments in Mach for X and A to see if the A works and X doesnt? If its still A not  working then it would suggest that its a drive or mobo issue and probably best to contact Gecko to see what they suggest.
Hood

Offline ger21

*
  • *
  •  6,288 6,288
    • View Profile
    • The CNC Woodworker
Re: Mach 3 Slave Axis problems.
« Reply #11 on: February 18, 2010, 08:37:57 PM »
My gecko does not have the option to move the drivers, they are static on a motherboard that attatches to the main board. 

I think you're mistaken. They should just plug in. The website even says "Easy to service, removable drives"
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html
Re: Mach 3 Slave Axis problems.
« Reply #12 on: February 18, 2010, 09:23:52 PM »
ok, let me pop that sucker open and give it the once over...
Re: Mach 3 Slave Axis problems.
« Reply #13 on: February 18, 2010, 09:33:42 PM »
Ok, I see how this thing works now, the drivers are seperate on the botom main board.  I have switched out A for X and X still works, and A does not...Same symptoms with thedriver boards swapped.  It has to be a software config problem.

Re: Mach 3 Slave Axis problems.
« Reply #14 on: February 19, 2010, 02:10:50 AM »
I think you have a cable problem.... you said the charge pump was switched off to get it to come out of fault but looking at the xml I think the charge pump should work properly... the charge pump on in e stop was checked and the pins looked correct.
Check the cable for continuity on all the pins.
I dislike the female connector on the g540 simply because a male to female cable will usually be a straight through / extension cable, but a male to male cable is more likely to be a serial or crossover or custom configuration...
but I think thats the only thing about them I don't like , I have several male to male adapters from days gone by  ;)
« Last Edit: February 19, 2010, 02:13:09 AM by Pandinus »

Offline Hood

*
  •  25,855 25,855
  • Carnoustie, Scotland
    • View Profile
Re: Mach 3 Slave Axis problems.
« Reply #15 on: February 19, 2010, 03:20:45 AM »
As Pandinus says it could well be the cable, you know the motors are good,  you know the drives are good so that leaves Mach, the parallel port, the cable or the G540 mobo as the culprits.
 If you swap pins for X and A  in Ports and Pins and the X motor still works then you know its a config issue, if the problem swaps then its hardware.

Hood
Re: Mach 3 Slave Axis problems.
« Reply #16 on: February 19, 2010, 06:56:09 AM »
Hey Crash,
  When you jog "X", does your "A(4)" DRO show movement as well ? Assume you did the restart after the slave setting.

Anybody....I"ve tried all I can find and cannot simulate A slaved to X .
Is the A dro disabled when slaved ? The manual suggests removing the slaved dro due to it not displaying offsets correctly to avoid confusion.
Un-slaved, it jogs and simulates as it should, slave it and restart then no dro movement for a.
I farted with this for quite a while last night and gave up.
I must be overlooking something. Tried ver 04, 20, 29 and 33.
Russ
Re: Mach 3 Slave Axis problems.
« Reply #17 on: February 19, 2010, 07:07:38 AM »
The DRO on the main screen shows up, I do not know how to remove it.
Re: Mach 3 Slave Axis problems.
« Reply #18 on: February 19, 2010, 08:12:29 AM »
Crash, the dro shows up here too as it should.
I'm asking you if your A dro displays the same positions as the x dro when you are jogging x.
On mine, the A dro never changes, always 0.0000
Russ
Re: Mach 3 Slave Axis problems.
« Reply #19 on: February 19, 2010, 08:39:24 AM »
no, it stays at 0.00000