Hello Guest it is January 27, 2022, 10:29:13 AM

Author Topic: Same plugin different computer - gives defect error and ignores  (Read 3829 times)

0 Members and 1 Guest are viewing this topic.

Same plugin different computer - gives defect error and ignores
« on: January 23, 2010, 08:42:02 AM »
My development machine is windows 7 and I am using .36 release of mach3. I developed a plugin which works fine on the development platform but when I move it to an xp platform with the same version of mach, I get the defective plugin error and it doesn't load it. Licenses are correct on both machines.
Re: Same plugin different computer - gives defect error and ignores
« Reply #1 on: January 23, 2010, 06:27:33 PM »
I am having the exact same issue. Are you using the standard SDK with VS 2003 or the MachPluginWizard with VS 2008 Express? I'm using the MachPluginWizard with VS 2008 Express. The weird thing is, i have emailed the plugin to someone else to test and they don't have any issues. But when i took it from my development PC to my machine PC i got the 'plugin defective' error and its ignored.
What version mach are you using?

Offline rcrabb

*
  •  146 146
    • View Profile
Re: Same plugin different computer - gives defect error and ignores
« Reply #2 on: January 23, 2010, 06:51:45 PM »
I think if your using the plugin wizard youll need to have the correct .net framework installed.
Ryan
Re: Same plugin different computer - gives defect error and ignores
« Reply #3 on: January 23, 2010, 09:51:42 PM »
On the development machine I am using the wizard from the 2008 converted to 2010. I am using the latest lockdown version. I have .net 4 framework but I can use any you suggest.

Offline rcrabb

*
  •  146 146
    • View Profile
Re: Same plugin different computer - gives defect error and ignores
« Reply #4 on: January 23, 2010, 10:08:18 PM »
on the other PC do you have the framework installed?
Ryan
Re: Same plugin different computer - gives defect error and ignores
« Reply #5 on: January 23, 2010, 10:24:51 PM »
That must have been it. Thanks. I should have guessed. I would think I would have gotten a complaint outside of Mach about the missing framework.
Re: Same plugin different computer - gives defect error and ignores
« Reply #6 on: January 23, 2010, 10:31:37 PM »
yeah, fixed my problem too. thanks. I assumed the latest .NET (available at the time) came with XP SP3. Downloading .NET 3.5 solved it for me.
Thanks again