Hello Guest it is January 26, 2020, 10:53:22 AM

Author Topic: MacroPump Doesnt Run  (Read 12994 times)

0 Members and 1 Guest are viewing this topic.

Re: MacroPump Doesnt Run
« Reply #10 on: January 17, 2010, 04:46:35 PM »
Hi Jason,

All correct in your observation and i am using the Mach label message display.

Phil
The Good Thing About Mach3, Is It's very Configurable

The Bad Thing About Mach3, Is It's Too Configurable

Offline zealous

*
  •  492 492
  • HI!
    • View Profile
    • Artsoft Solutions
Re: MacroPump Doesnt Run
« Reply #11 on: January 17, 2010, 05:34:59 PM »
I give the user 2 seconds to change it to MM after the estop is hit or it estops the sytem again.

Code: [Select]
Dim Inch_mode As Boolean
Dim Estopped As Boolean

Estopped = GetOEMLED(800)
Inch_mode = GetOEMLED(801)

If(Inch_mode)Then

'Is the sytem estopped already
If Not(Estopped)Then
'Estop system
DoOEMButton(1021)

End If

While(GetOEMLED(800))
MESSAGE "Went Into Inch Mode:"&i
sleep(250)
Wend

'Give the user time to change to mm?
Sleep(2000)

End If
Re: MacroPump Doesnt Run
« Reply #12 on: January 17, 2010, 05:55:37 PM »
Hi Jason,

Thank you so much, it beats checking a custom screen with a flashing red led 25mm x 50mm while turning the MPG. ;D

It's so easy when you know how, i would never have got that.

Phil
The Good Thing About Mach3, Is It's very Configurable

The Bad Thing About Mach3, Is It's Too Configurable

Offline zealous

*
  •  492 492
  • HI!
    • View Profile
    • Artsoft Solutions
Re: MacroPump Doesnt Run
« Reply #13 on: January 17, 2010, 09:47:43 PM »
Great to hear!
I wasn't sure that was what you wanted, but you can make changes and maybe have it force it back to MM mode or something :)
Re: MacroPump Doesnt Run
« Reply #14 on: January 18, 2010, 10:45:59 AM »
Jason,

I can understand the workings, with a bit of thought  :-[, but why fix something that isn't broke. ;D ;D ;D

Phil
The Good Thing About Mach3, Is It's very Configurable

The Bad Thing About Mach3, Is It's Too Configurable