Hello Guest it is December 15, 2019, 08:45:45 PM

Author Topic: Spindle no longer crashes Mach3, but doens't stay on...  (Read 7172 times)

0 Members and 1 Guest are viewing this topic.

Offline BarryB

*
  •  267 267
    • View Profile
Re: Spindle no longer crashes Mach3, but doens't stay on...
« Reply #10 on: January 10, 2010, 01:42:22 PM »
I didn't expect the 'Limit' switches to be the cause of this, but if I put the noise filtering to '5' on that, it all work.  I'm going to put 'limits', 'estop' and 'misc' at 5.  Thanks for the prodding.  I can't tell you how happy this makes me;)

Barry

Offline Tweakie.CNC

*
  • *
  •  8,024 8,024
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Spindle no longer crashes Mach3, but doens't stay on...
« Reply #11 on: January 11, 2010, 12:29:19 PM »
Hi Barry,

Sorry to be bit of a killjoy on this but although your limit switches are the manifestation of the problem they are not the root cause or source of the problem which, in my opinion, is definitely noise related and your limit switch wiring is just the antenna. Increasing the debounce setting may well mask the noise but, as Hood has said, you must consider that this is the time interval taken by Mach to recognize any limit switch being triggered and if the limit switch is mounted too close to the machine’s mechanical stop it will not perform it’s intended function.
I have recently fitted a VFD and can vouch for their noise potential but if it is correctly fitted there should be no problem. Although it is a vast subject here are a couple of easy things you could try before getting in too deep.
1. Check you have a proper and good ground connection coming into your machine.
2. Check that the VFD is grounded in accordance with the makers installation instructions.
3. Check that you have no ground loops on the machine (screened cables grounded at both ends etc.). A single point ground (with all shields and ground connections terminated at this one point) would be an ideal situation.
4. VFD driven motors can build up a charge on their rotor shafts (caused by stray flux) which will discharge to ground through the bearings and in so doing cause electrical noise. This can be tested for by temporally connecting the spindle shaft to ground with a carbon brush or similar. (large motors often have more than one brush in contact with the shaft to achieve this and prevent the bearings from pitting).
5. Your computer ground and your machine ground should not form a loop. (again only connected at one end, which is usually at the incoming mains supply). This may be particularly difficult to test for due to the many signal connections and their ground returns.

Waffled on a bit but I hope this helps.

Tweakie.
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.

Offline BarryB

*
  •  267 267
    • View Profile
Re: Spindle no longer crashes Mach3, but doens't stay on...
« Reply #12 on: January 11, 2010, 12:48:30 PM »
Thanks Tweakie, I'm going to live with what I have right now till I build a new control box.  You saw my wiring did get out of control once I added all the connections, and I have no doubt that stowing them properly and having a bit of space between components will help.  I'll upgrade the cabling too.  They aren't shielded like you'd want them to be.  I plan on doing that in the next couple of months.

I posted a pict of my wiring diagram on the show off your machines category.  It's a bit messy even in that;).  I can link my 5v and 65v ground contact boards too.  That will share that ground and hopefully help as well.

Barry
Re: Spindle no longer crashes Mach3, but doens't stay on...
« Reply #13 on: February 21, 2010, 09:47:13 AM »

5. Your computer ground and your machine ground should not form a loop. (again only connected at one end, which is usually at the incoming mains supply). This may be particularly difficult to test for due to the many signal connections and their ground returns.

Waffled on a bit but I hope this helps.

Tweakie.

My VFD is 3 phase 415 volt and the earth to the motor comes from this power point.
The PC and servo drives are earthed through the 240 volt power point.
The lathe will always be earthed even if the 240 volt side is not plugged in,
but will probably create a ground loop.

Is this acceptable or should I disconnect the earth from the 415 volt supply ?

I have noise issues since installing the VFD. - ( S-true displays fluctuating from 100 to 43000 rpm
when actual speed is 300 RPM, X axis moving by itself )
I'm getting about 1.2 volt spikes on the 0 volt terminal of the spindle index pulse receiver.

 Glen.
I had a few parts left over - still it's always the same when you try a bit of "do it yourself"

Offline Tweakie.CNC

*
  • *
  •  8,024 8,024
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Spindle no longer crashes Mach3, but doens't stay on...
« Reply #14 on: February 21, 2010, 11:06:31 AM »
Hi Glen,

Difficult to tell without looking at your installation.

The casing of my VFD (the heatsink) is bolted directly to my machine frame and is therefore grounded by this fixing so the incoming supply to it does not contain a ground connection. The output from the VFD is made with shielded cable, grounded at the VFD end but not at the motor end but the motor is itself grounded by being bolted to the machine frame. My machine frame and the computer casing are the only parts which are directly connected to earth protective ground and the screen of the LPT cable does not connect the two parts. So everything is ultimately connected to ground without loops and all works well.

Hope this helps,

Tweakie.
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.
Re: Spindle no longer crashes Mach3, but doens't stay on...
« Reply #15 on: February 22, 2010, 05:11:24 AM »
Update - There is now only 1 earth to the machine ( the VFD one ). The computer earth and the VFD earth were connected because the power supply case was bolted to the lathe ( painted surface which may have created an intermittent connection). The noise was an intermittent problem.

 There is another issue which I suspect is a glitch in Mach 3. The X axis moves every few seconds by itself in a positive direction when there is an index pulse. If the motor is running and I disconnect the index pulse the random movements stop.

These are commanded moves from Mach 3 - ie the DRO on the screen moves. It seems to hold position during a cut from G Code but starts moving again during feed hold or with no G Code loaded.  I have disabled the MPGs in "Ports & Pins".

I'm using version R2.3 according to the "About Mach 3" under "Help". I haven't updated because I mainly do threading on this lathe and it does that well.  

This is a separate problem and needs to be under another topic in the forum.

Glen.
I had a few parts left over - still it's always the same when you try a bit of "do it yourself"

Offline Tweakie.CNC

*
  • *
  •  8,024 8,024
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Spindle no longer crashes Mach3, but doens't stay on...
« Reply #16 on: February 22, 2010, 09:04:59 AM »
Sorry Glen, can't help with this one - Its outside the realms of my personal experience.  :'(
Somebody will know the answer to this.

Tweakie.
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.