Hello Guest it is November 30, 2021, 04:08:21 PM

Author Topic: low pulse frequency in drivertest  (Read 6728 times)

0 Members and 1 Guest are viewing this topic.

low pulse frequency in drivertest
« on: January 04, 2010, 02:13:07 PM »
Hi;

I am a newb here and just putting together a PC to run my CNC router (not here yet).  After a clean install XP service pack 2 and upgrades, now SP3, and a new install of the latest Mach3, I am getting the following on drivertest-

Computer
1.6 ghz P4 with 512 mbytes RAM

Drivertest
frequency   12318
system       Excellent
CPU           1593
short          79.3 us
long            83.8 us
apic timing   8100
Max Var      5.8-7.3

The graph line is above the display, with occasional short spikes below


When I run Mach 3, diagnostics says pulse frequency is 23209 and variation is in the +7 to +10 range

I have run all the optimization.txt items and the system is running clean.

Any suggestions?

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: low pulse frequency in drivertest
« Reply #1 on: January 04, 2010, 04:06:47 PM »
If this is the latest version of Mach try an older version, Art has done some things to the driver for threading and this may or may not be causing issues on some computers.
Hood

Offline bowber

*
  •  216 216
  • Kirkby Stephen,Cumbria, UK
    • View Profile
Re: low pulse frequency in drivertest
« Reply #2 on: January 04, 2010, 04:19:56 PM »
My driver test is similar, below 24000 and with spikes in the graph. P4 1.? ghz cerca 2001 with windows 2000 pro clean install and about 512mb ram
I'll check tomorrow but it runs my router fine at 2m/min rapids and is smooth etc.
Give it a try and see how it does.

Steve
Re: low pulse frequency in drivertest
« Reply #3 on: January 04, 2010, 06:39:32 PM »
 ;D Success!

I uninstalled Mach3, downloaded and installed Mach2, rebooted and ran Drivertest

Result-

Pulse frequency    24088
CPU frequency       1593

Graph shows 41 us with short spikes

I downloaded Mach3 again and reinstalled it, got the same result as before.  I then went to the Mach3 folder and tried to run OriginalDriver.bat as suggested in the manual.  It did not run correctly - I had to change Mach3.noapic to Mach3.orig as listed in the .bat file I suppose I could have edited the .bat file, but this seemed easier.

Reboot (which may not have been necessary) and ran Mach3 drivertest.exe

Result

Pulse frequency     24396
System                 Excellent
CPU frequency        1594
shortest              36.437
longest                42.723
Max             6.04 - 13.0

The graph is as 41 us or so, and is a little spikey, with internet connected and antivirus running, so I can clean it up a bit

Mach3 diagnostic reports pulse freq of 25386

Thanks for your help, excellent support...

Mike R in rainy Vernon, BC, Canada






Re: low pulse frequency in drivertest
« Reply #4 on: January 07, 2010, 11:19:36 PM »
I just posted a question regarding similar problems to what you just described. What is the method that needs to be followed here to accomplish what you did.

1. Is it necessary to install Mach2, then uninstall it? What does that do?
2. Can I just re-name the Mach3.noapic file to Mach3.orig as you mentioned. Seems a lot quicker???

Thanks
Re: low pulse frequency in drivertest
« Reply #5 on: January 07, 2010, 11:34:45 PM »
hi, It happened to me running the driver test the result of frequency was the half  (12khz aprox) but return the intent several times obtained the result correct of 24khz approximately, is this normal?

greeting.
Re: low pulse frequency in drivertest
« Reply #6 on: January 08, 2010, 01:17:08 AM »
Well, that worked on the machine where I have the APIC disabled, but on my faster machine where I've been unable to disable the APIC due to a driver chipset failure, the change causes the driver test program to fault/freeze. Is there a way to get the test to run without the APIC disabled.

Also, is this file swap procedure only changing the way in which the speeds are reported/calculated, or is it changing some feature which allows the test to run at a higher rate?

Thank you,
Re: low pulse frequency in drivertest
« Reply #7 on: January 08, 2010, 01:06:09 PM »
controlfreq wrote:
1. Is it necessary to install Mach2, then uninstall it? What does that do?
2. Can I just re-name the Mach3.noapic file to Mach3.orig as you mentioned. Seems a lot quicker???

and

Well, that worked on the machine where I have the APIC disabled, but on my faster machine where I've been unable to disable the APIC due to a driver chipset failure, the change causes the driver test program to fault/freeze. Is there a way to get the test to run without the APIC disabled.

Also, is this file swap procedure only changing the way in which the speeds are reported/calculated, or is it changing some feature which allows the test to run at a higher rate?


I don't know if the new driver (for clarity, the port driver is the file named Mach3.sys in the Mach3 folder) actually runs the port (on some computers) at half frequency, or just reports the pulse rate at double, or frequency at half the actual.  If I use the new Mach 3 driver, it reports the frequence at 12000 in drivertest, however if I run Mach3, the diagnostics reports the frequency as 24000.  I don't have motors hooked up, so I can't do a 'real world' test.

The driver swap procedure is in the manual, asking you to run the DOS batch file OriginalDriver.bat  This batch file says
del  mach3.sys
copy mach3.orig mach3.sys
REM.exe *Mach3
IN.exe  .\Mach3.inf *Mach3

or
Delete Mach3.sys              #the new driver
Copy Mach3.orig mach3.sys #copy the original driver to Mach3.sys
REM.exe *Mach3               #REM is a utility that removes drivers from the operating system - this removes the new driver at the system level
IN.exe .\Mach3.inf *Mach3  #IN is a utility that installs the driver specified in Mach3.inf (i.e.what was Mach3.orig above) at the system level

The distribution I used (3.042.032)  has the original driver (or its equivalent) named Mach3.noapic and so the batch file above will not run correctly unless you change Mach3.noapic to Mach3.orig.

I note that the new distro has a few changes.  It may be that this driver test will fix the bug

--changelist report -- (excerpt)

Dec 23/2009
Release 3.042.033
-- Fix for - scale and IJK arc commands
-- Spindle speed register expanded for computers over 3GHz (they where reading - speed)
-- Rotational feed correction fixed for moves with Z axis !=0
-- Rotational Dia feed changed to Radius rather then Dia


Jan 05/2010
Release 3.042.034
-- Driver Frequency locking in at proper Hz
-- Spindle not turning on bug fixed
-- new Driver test added to show Rev of Driver


Jan 07/2010
Release 3.042.035
-- Driver update to stabilize Pulse rate more