Hello Guest it is July 19, 2019, 05:17:55 PM

Author Topic: Has anyone seen this before?  (Read 4082 times)

0 Members and 1 Guest are viewing this topic.

Has anyone seen this before?
« on: September 09, 2006, 10:26:35 PM »
Hi,  I'm attempting to run a toolpath generated in VCarve Pro of the Intel logo.  All appears to work correctly until I load the .Txt file generated by VCP in Mach 3, then there is a group of circles (donut? torus?) added to the toolpath screen.   At first I thought it was an artifact from VCP, but I posted the .Txt on the VCarve forum and others were able to view it correctly, so I think the problem is with Mach 3.  I have rebooted, no help.  I installed the latest update of Mach 3 and the donut got bigger, but I can't get rid of it.

Hopefully someone out there has run into this before and can tell me what I'm doing wrong.  Thanks in advance for any help!

R/L
Re: Has anyone seen this before?
« Reply #1 on: September 09, 2006, 11:07:25 PM »
Look under your configuration for an IJ Mode- try changing it to Incremental (it sounds like you have it set to absolute)  Good Luck
Re: Has anyone seen this before?
« Reply #2 on: September 11, 2006, 06:14:56 PM »
 ;D Thanks ToS, that was it!  I'm not sure how that option got set incorrectly.  Is that something that the file itself can change?  I can see that I need to study the G code a lot more.

Thanks again,

R/L

PS: Here's the nearly finished sign...
« Last Edit: September 11, 2006, 06:18:08 PM by rlinscheid »
Re: Has anyone seen this before?
« Reply #3 on: January 10, 2007, 03:28:02 PM »
Has anyone solved this problem?  I'm seeing it bigtime and changing from absolute/incremental doesn't do the trick.  I get smaller circles, but still seeing bogus circles in the toolpath.  I'm using BobCAD 20.7 with the newest Mach3 driver.  If I generate from NC, it looks fine in the CAD program, but Mach still generates those crazy extra circles.

Thanks!  -Steve

Offline fdos

*
  •  326 326
    • View Profile
Re: Has anyone seen this before?
« Reply #4 on: January 10, 2007, 05:19:16 PM »
You have to set Mach to wahtever your post processor is outputing.

The norm seems to be Incremetal IJ, Mach when in this mode will also accept R as Valid.

It might be you need to look at your post.

Wayne...
Re: Has anyone seen this before?
« Reply #5 on: January 12, 2007, 08:20:41 PM »
Thanks for the advice.  The settings all seem to be synched up.  My actual problem seems to be a bug in BobCAD that happens when creating tiny little arc segments.  I don't fully understand what is happening, but it can be solved by changing accuracy settings.  Interestingly enough, the gcode simulates just fine in BobCAD, probably because the same rounding calculations are used for interpreting the code as generating it.

Steve