Hello Guest it is May 23, 2019, 03:39:06 PM

Author Topic: Z-axis motor tuning problem - resets to 0 automatically (Smoothstepper)  (Read 6039 times)

0 Members and 1 Guest are viewing this topic.

Offline Hood

*
  •  25,813 25,813
  • Carnoustie, Scotland
    • View Profile
Re: Z-axis motor tuning problem - resets to 0 automatically (Smoothstepper)
« Reply #10 on: November 10, 2009, 05:53:08 AM »
Those are the latest versions and should work together.
 Not sure where your problem lies but if you attach both your SS xml and PP xml I will see if I can find a problem there.
Hood

Offline Bfive

*
  •  13 13
    • View Profile
Re: Z-axis motor tuning problem - resets to 0 automatically (Smoothstepper)
« Reply #11 on: November 10, 2009, 11:55:58 AM »
I've attached both. Thanks!
« Last Edit: November 10, 2009, 12:20:50 PM by Bfive »

Offline Hood

*
  •  25,813 25,813
  • Carnoustie, Scotland
    • View Profile
Re: Z-axis motor tuning problem - resets to 0 automatically (Smoothstepper)
« Reply #12 on: November 10, 2009, 03:07:15 PM »
You have the E-Stop set to Pin 0 in the SS xml, not sure if that would be an issue or not as it will depend how you have things set up.
Another thing to check is that you have chosen to use Pin2-9 as inputs in the SS config page. and make sure you have the cables plugged into the correct ports on the SS.
 Do you see the red LED flashing away on the SS?

Hood

Offline Bfive

*
  •  13 13
    • View Profile
Re: Z-axis motor tuning problem - resets to 0 automatically (Smoothstepper)
« Reply #13 on: November 10, 2009, 10:43:00 PM »
My E-stop is setup as a hotkey. I've tried changing the E-stop pin but it doesn't seem to help. I changed Pin2-9 to output but that doesn't seem to help either. My cables are plugged into Port1 on the smoothstepper, step ports and enable ports are set to Port1 in Mach3... that's correct right?

The LED flashes when Mach3 is running with SS plug-in.

Offline Hood

*
  •  25,813 25,813
  • Carnoustie, Scotland
    • View Profile
Re: Z-axis motor tuning problem - resets to 0 automatically (Smoothstepper)
« Reply #14 on: November 11, 2009, 03:04:01 AM »
Sounds like its set up right and that the SS is communicating with Mach.
 Just double check that you have the cable plugged in the right way round as it is possible to put it in wrong if there is no key on the ribbons plug.
Other than that I dont know what to suggest, maybe have a look in the SS Diagnostics and see if there is anything flagged that shouldnt be.

Hood