Hello Guest it is January 24, 2020, 08:58:19 AM

Author Topic: Mach 3 shifts the toolpath to the left after 3minutes of cutting? Parts overlap!  (Read 3155 times)

0 Members and 1 Guest are viewing this topic.

Offline matd

*
  •  17 17
    • View Profile
Hi,

this is my problem:
I make a G code with lazycam (tried both new and older version, does not solve the problem).
Import it into mach3.
It runs fine for 2-3 minutes.
After this, always at the same part, mach 3 shifts all of the parts to the left (see image).
this:

becomes this:

I have no idea why.
When I import the G code in mach is looks allright on the toolpath viewer, but when it runs it, it goes wrong.
Anyone can help me please?
Thank you
« Last Edit: November 07, 2009, 05:38:41 PM by matd »
What version are you using?

Check out my post "Problem in Mach3 R3.042.029?". Do you think your having the same problem as me?

So the top image is what is previewed, and the bottom image is the actual toolpath?

Offline matd

*
  •  17 17
    • View Profile
yes that's right.
Top image is what it should be and what is showing when loading the G code into mach.
The bottom view is what comes out (what is being cut).
I'll check out your topic

Offline ger21

*
  • *
  •  6,291 6,291
    • View Profile
    • The CNC Woodworker
When the cutting shifts, does the DRO show the position where the tool is, or where it's supposed to be?
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html

Offline matd

*
  •  17 17
    • View Profile
When the cutting shifts, does the DRO show the position where the tool is, or where it's supposed to be?
I'll check that tomorrow.
The strange thing is that the problem always starts at the same part, and that the shifted result is perfectly symmetric.
I am quite sure you will find that the DRO will display where it is supposed to be. Could you tell us what version/build of Mach 3 your using?