Hello Guest it is October 17, 2021, 02:20:04 AM

Author Topic: Mach memory cache annoyance  (Read 13182 times)

0 Members and 1 Guest are viewing this topic.

Offline Chaoticone

*
  • *
  •  5,626 5,626
  • Precision Chaos
    • View Profile
Re: Mach memory cache annoyance
« Reply #10 on: October 07, 2009, 10:12:43 PM »
Do me a favor. Open the code in Mach and leave it open. Then go into PCB G-code and make a change and save it. See if it will let you save it while it is loaded in Mach.

Brett
;D If you could see the things I have in my head, you would be laughing too. ;D

My guard dog is not what you need to worry about!

Offline RICH

*
  • *
  •  7,419 7,419
    • View Profile
Re: Mach memory cache annoyance
« Reply #11 on: October 07, 2009, 10:32:14 PM »
I have never seen that behavior.
New one to me also.

RICH

Offline RICH

*
  • *
  •  7,419 7,419
    • View Profile
Re: Mach memory cache annoyance
« Reply #12 on: October 07, 2009, 10:40:29 PM »
HMM...
Close both appications. Do a Windows search of the file name. There should only be one file in one location with that name. If there are more than one get rid of the others.
RICH

Offline Sage

*
  •  365 365
    • View Profile
Re: Mach memory cache annoyance
« Reply #13 on: October 07, 2009, 10:49:34 PM »
I tried your suggestion.
If the file is open in Mach then PCB-Gcode gives an error - access denied...
I would have expected this since Mach does need to open the file and presumably it keeps it open - locking it just in case you want to edit it or something.
The problem comes when you close and then re-open it. Mach apparently reads it from memory, not from the file the second time around (as already detailed previously).

Anything else you'd like to try. (tomorrow) ?

Sage

Offline Sage

*
  •  365 365
    • View Profile
Re: Mach memory cache annoyance
« Reply #14 on: October 07, 2009, 10:58:25 PM »
There is only one file with that name. It's in my Eagle projects directory. When I open Mach it defaults to the last place you got files from which is at the moment is the same Eagle directory.
 As mentioned it's not like Mach is picking up the wrong file every time (i.e looking in the wrong place at the wrong file). It's quite happy to open the updated file as long as you exit Mach and return.

Thanks to all for helping.

Catch you tomorrow. I have to sleep on it for a while.

Sage

Offline Sage

*
  •  365 365
    • View Profile
Re: Mach memory cache annoyance
« Reply #15 on: October 07, 2009, 11:36:45 PM »
Ok one last thing for tonight.
I forgot that the files have a date and time stamp in the G-code header.
I noticed that Mach IS loading the latest file.
 But I had always been using the big toolpath display (you get when you press the toopath button) because I have to zoom in a lot to see the artifact I'm changing settings to get rid of and it's easier to see.
In any case if I zoom in on the little toolpath display it is fine.
The big tool path is the one that does not seem to pick up the changes. Maybe it's caching old information. The two displays are different.
Even though the small toopath does go blank and appear to refresh when you load the new file. I guess the big one is not.
If I do a regen while on the big tool path it updates to the new file as well.
I thought I'd tried the regen before with no help but I've been back and forth so much I might have gotten confused what I was supposed to see.

In any case it does seem to be a big toolpath display refresh/caching problem.

Sage
« Last Edit: October 10, 2009, 02:21:20 PM by Sage »

Offline Sage

*
  •  365 365
    • View Profile
Re: Mach memory cache annoyance
« Reply #16 on: October 10, 2009, 02:46:47 PM »
Hood:

There is a minor problem with Mach (as mentioned above). The big toolpath display seems to be fooled by file changes.

Try this. It exhibits the problem for me.

Take a G-code file and copy it to another file with a slightly different name (so they can co-exist in the same directory).
Edit the second file so it does something obviously different that can be seen in the toolpath. Try not to make the file too much bigger though.

Start Mach and load the first file into Mach and display it on the big toolpath display.
Go back to the main Mach page and "close G-code". Keep Mach running.

Go to a new windowand with windows explorer rename the first file (the one you just open in Mach) to sometihng else and rename the second (modified file) to the same name as the first file was.

Go back to the Mach window and load the modified G-code file (which now has the same name as the original file loaded into Mach).

In the main page toolpath you should see the modified file toopath fine.

If you switch to the big toolpath display you will still see the original file displayed instead of the new one.
A regen will update the display to the new file.

This displays the problem every time for me. It's not a big deal but I feel that if you close a G-code file it should clear it out of the whole program and should not be lurking inside the program somewhere.
Just another small thing to add to the list (please).



Sage


« Last Edit: October 10, 2009, 02:49:15 PM by Sage »

Offline ger21

*
  • *
  •  6,293 6,293
    • View Profile
    • The CNC Woodworker
Re: Mach memory cache annoyance
« Reply #17 on: October 10, 2009, 07:31:50 PM »
Do you have the driver installed?
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: Mach memory cache annoyance
« Reply #18 on: October 10, 2009, 07:46:19 PM »
Just tried doing exactly what you said and it works perfectly for me, Ger may be on to something re the driver if you are just simulating.
Hood
Re: Mach memory cache annoyance
« Reply #19 on: October 10, 2009, 09:21:28 PM »
Hello all,

I think, I also noticed this phenomenon in the past:

After modifying the G-Code file (even from inside Mach3 with the "Edit" button) the small toolpath window refreshes automatically and shows the changed toolpath, but the big one does not. You have to refresh it manually to see the contents correctly.

Might this behave different depending on graphics board in the PC? (I don't have an idea, as I don't know how and where the toolpath displays are generated.)

Maybe this point should be on the task-list for revision 4.


Konrad