Hello Guest it is December 01, 2021, 09:39:16 AM

Author Topic: jogging slow and limit switches won't work  (Read 4095 times)

0 Members and 1 Guest are viewing this topic.

jogging slow and limit switches won't work
« on: September 19, 2009, 10:32:47 PM »
Mach 3 seems to behave differently every time I turn it on. 1-  I can't jog full speed - Abnormal Condition light blinking CV vs full stop, and the log tells me a limit switch has been triggered, but hasn't. Also, the switches don't stop the machine when they are tripped. New to Mach 3; got the table & software from another person. Having depth setting problems as well. Using LazyCam to output Gcode; doing simple 2D AutoCAD dxfs to rout polycarbonate sheets .1875"(3/16"), 4.7625mm. not using this to mill anything complicated, yet I cannot seem to get it to run consistently. Constantly ruining material and wasting time and money. How do I reset the machine? How do I get my normal jogging back, with limit switches behaving properly? How do I set an origin point that the software will remember and start from without having to configure it every time I power it on? Also, whenever I want to drill a hole, it pecks at the hole twice with some holes, but only once with others. I'm a CAD pro but this software makes my brain hurt. Apologies for the serial questioning. Perhaps I need to reinstall the software?

Offline Chaoticone

  • *
  •  5,626 5,626
  • Precision Chaos
    • View Profile
Re: jogging slow and limit switches won't work
« Reply #1 on: September 20, 2009, 11:50:34 AM »
First problem I would look at is the limit switch. You won't be able to rapid jog or ref. the machine if it thinks a limit is already active. You want be able to set a zero position and return to it if the machine doesn't know where it is either. You may have a problem with noise, bad switch, wireing, ect. Look in the support tab at the top of this page, documentation and have a look at the manual. Also post you xml and the version number your running.

;D If you could see the things I have in my head, you would be laughing too. ;D

My guard dog is not what you need to worry about!
Re: jogging slow and limit switches won't work
« Reply #2 on: September 24, 2009, 07:01:28 PM »
Can't get cnc router to home properly.
 I'm back with more problems.. Thanks to the help on this forum I solved my frequency problem.. Now I am  getting close to actually cutting something with my homemade cnc router. I am able to move all axes, but I cannot get them to home properly. I have not installed any limit devices yet. I cannot get the green lites to go on any axes either. I read some earlier post and tried all those suggestions and got no where. My table on the video screen shows my part to be to the outside bottom cross hairs of  the machine coordinates.  Any help as always will be greatly appreciated.


Offline Hood

  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: jogging slow and limit switches won't work
« Reply #3 on: September 24, 2009, 07:36:58 PM »
If you dont have any home switches then you can do it two ways. First is  press RefAll button wherever you are then move to where you want to have the parts zero position as and press the zero button at the side of each axis DRO. What that will do is set the offset zero position and if you then regenerate your screen the part should look correct. The first part is not really needed as all it will do is set the LEDs  Green but you will have no benefit.
 The other option would be to jog to the extremes of each axis  amd have some means of knowing the exact position (a scribed line etc) then press the RefAll button and then do as above. What that will do is set your machine coords to zero and  then you will jog and set the offsets zero.
The advantage to doing it that way is if you can do this on each startup you can then go to the previously saved offset zero and restart your cutting. How good it will work depends  on how accurate you can be with the position you have the axis at when pressing the RefAll button.

Re: jogging slow and limit switches won't work
« Reply #4 on: October 05, 2009, 01:09:40 PM »
Problem was a wire pulled from its post inside one of the limit switches. Thanks