Hello Guest it is January 22, 2022, 06:47:41 AM

Author Topic: I cannot figure out what LCam is doing?  (Read 10000 times)

0 Members and 1 Guest are viewing this topic.

Re: I cannot figure out what LCam is doing?
« Reply #10 on: August 08, 2009, 10:58:24 AM »
Rich, there must be something wrong with my installation of Lcam.  I have done the steps you mentioned over and over again with the same results.
Lets just drop it, I will just keep using notepad to search and replace all occurances where Lcam places Z0.1000 in the code.

vmax549

*
Re: I cannot figure out what LCam is doing?
« Reply #11 on: August 08, 2009, 12:23:10 PM »
SO you don't want to know HOW to fix your problem??

Thse are just settings that YOU put into play.

(;-) TP
Re: I cannot figure out what LCam is doing?
« Reply #12 on: August 08, 2009, 01:12:53 PM »
In the screen shots I posted, did I not fill in the correct text boxes?

Offline RICH

*
  • *
  •  7,422 7,422
    • View Profile
Re: I cannot figure out what LCam is doing?
« Reply #13 on: August 08, 2009, 04:30:32 PM »
Drools,
I looked at your  LCAM. In the Layer menu You have a rapid height  of  .1" , so every rapid  ( the move from one chain to the next chain ) will be .1" above the Z=0  ref.  You have a tool picked and that tool is restricted to .0625" cut depth.  What is missing is that you have not told LC where you want the tool to start cutting and also how deep you want the tool to cut below  the Z=0 ref plane.  Note that the cut depth should be a negative number.


You don't want to delete all the references to the rapids. You will cut through the face of the piece.
 A more logical way of machining the piece would have been to put the outline / boarder around the text on a  layer so you could cut that differently than the text. Then have all of the text on a  layer. But if you just want to machine it all the same then leave it as it.


You tell the LC how you want to machine the part. LC is really stupid , it only knows what you tell, but once you
tell it , it will do as you say!

Each one of the tutorials in the manual has something to say about layer tab and cutting.

RICH

Offline RICH

*
  • *
  •  7,422 7,422
    • View Profile
Re: I cannot figure out what LCam is doing?
« Reply #14 on: August 08, 2009, 06:16:03 PM »
Sent you a personal message.
RICH

Offline RICH

*
  • *
  •  7,422 7,422
    • View Profile
Re: I cannot figure out what LCam is doing?
« Reply #15 on: August 08, 2009, 07:42:30 PM »
Drools,
Some information:
1. Not having a license is not the problem.
    If you don't have a LC license you will see in one of the buttons for the POCKET, OFFSETS, FOAM2D, TURN menu
     "Pro Demo.NoCode"
    I can't say if there is anything else restricted.
2. You need to click the "set layer" button for the cuts, and when you do you will see a "change" in the display.
    Just clicking the "Set All Layers" is not resetting the Z movements. That is why when you post to MACH you keep
     getting the previously set Z. (Need to look at it more closely with something that has multiple layers.)

3. Like you said in the other post, highlighting all the text along with a backspace when in the setup menus will
    cause the program to shut down.

I will get them into the manual as "blue text"  and also add a know "bug" page to the manual.

RICH
Re: I cannot figure out what LCam is doing?
« Reply #16 on: August 08, 2009, 08:58:58 PM »
Thank you Rich, I was playing with the "Set Layer" and "Set All Layers" buttons when we were talking and that is when I noticed that they both did different things. The "Set Layer" worked while the "Set All Layers" did not. Of course all I was trying before was the "Set All Layers" button.
The one last item is the "Plunge Clearance" this parameter is set from the Setup-->Posting Options menu. Since I can setup the Rapid Height, Cut Start and Cut Depth in the Layers tab it would be nice to have this turned off if we do not need it.
In the PDF Manual version 8/5/2009 REV:0 I could not find a reference to this setting. I have googled it and not really much of an answer to exactly what it is and why we need it. I'm sure it will be handy at some point but right now I would like to turn it off.
Thanks again for your help and it was nice talking to you.
Re: I cannot figure out what LCam is doing?
« Reply #17 on: August 10, 2009, 01:57:42 PM »
I have been playing with Lcam and a 3 layer dxf. It works pretty well but I have not used the "Set All Layers" button anymore.
One thing I did notice and I hope someone will try it and confirm. In the setting mentioned in the previous post Setup-->Posting Options "Plunge Clearance" (PC) try setting it to something different to what is set in the Layers-->Rapid Height (RH) textbox.  Have a look at the resulting gcode for a reference to this Z PC and a reference to the RH you should see both. The PC will not have a rapid code (G0) but rather a reference to the Z height like this Nxx Z0.1234. The RH reference will have a rapid code G0 like this Nxx G0 Z0.2500 . Now go back to Lcam and make the PC the same as the RH value and export to Mach3, no more do we have a line with a reference to PC all we see are the rapids Nxx G0 <RH>. If I'm correct the code is checking both settings and if different adding both and if the same, dropping the PC value.
If someone has a chance to verify please do, thanks.

BC

Offline RICH

*
  • *
  •  7,422 7,422
    • View Profile
Re: I cannot figure out what LCam is doing?
« Reply #18 on: August 10, 2009, 04:15:03 PM »
BC,
I am playing with that also ( updating the manual  ;D ).  Not sure in my reply #15 / info 2. remark is
totaly correct. So will fool with it and try to find the logic or bug.
I am using the shapes file that i posted as it's easy to see what is happening.
There is also a definiton on what the plunge clearance does in the manual, thanks to VMAX.
But i also want to look at the generated code. I just want to check it out in a disciplined way.

RICH

vmax549

*
Re: I cannot figure out what LCam is doing?
« Reply #19 on: August 10, 2009, 06:52:21 PM »
THe plunge clearance is the value above the Top of material that you would like MACH to Rapid down to, then feedrate on down to the cut point.

When Mach pulls UP to a safe Z this controlls the rapid back down to the control point

IF you set it to zero then MACH will NOT rapid down it will feedrate down instead.  VERY VERY slowly(;-)

(;-) TP

« Last Edit: August 10, 2009, 06:55:39 PM by vmax549 »