Hello Guest it is January 25, 2020, 02:24:59 PM

Author Topic: high speed problem...  (Read 4091 times)

0 Members and 1 Guest are viewing this topic.

high speed problem...
« on: July 26, 2009, 09:23:39 PM »
Hi,

I have a problem is that when I tried to increase feedrate to 2000, the angles will become radians...



each x,y&z uses same size AC servo & ball-screw.

is any setting wrong? ???

Thanks.

G code as below:
(File a )
(Monday, July 27, 2009)
G90G80G49
G0 Z0.0000
G90.1
G0 Z0.0000
M5
M6T1
M3
S2000
G0 Z0.0000
G0 X16.8291 Y5.3868
M3
F300.000G1 Z-2.0000
F2000.000G1 X44.6850 Y5.3868
G1 X44.6850 Y38.5996
G1 X16.8291 Y38.5996
G1 X16.8291 Y5.3868
G0 Z0.0000
G0 X58.8161 Y44.1707
F300.000 G1 Z-2.0000
F2000.000 G2 X58.8161 Y44.1707 I71.2552 j44.1707
G0 Z0.0000
G0 X66.7554 Y74.1694
F300.000G1 Z-2.0000
F2000.000G1 X30.9714 Y68.8125
G1 X47.8991 Y93.8827
G1 X66.7554 Y74.1694
M5
G0 Z0.0000
G0 X0 Y0
M5M30
Re: high speed problem...
« Reply #1 on: July 26, 2009, 09:33:47 PM »
Probably because you're running a relatively high feedrate, with a relatively low acceleration.  When running in constant velocity mode, something's gotta give, and it's sharp corners.  Either increase acceleration, or decrease feedrate.  I believe using exact stop mode will also cure that, but at a cost....

Regards,
Ray L.
Regards,
Ray L.
Re: high speed problem...
« Reply #2 on: July 26, 2009, 10:07:45 PM »
Probably because you're running a relatively high feedrate, with a relatively low acceleration.  When running in constant velocity mode, something's gotta give, and it's sharp corners.  Either increase acceleration, or decrease feedrate.  I believe using exact stop mode will also cure that, but at a cost....

Regards,
Ray L.

Hi HimyKabibble,
Firstly, thanks for reply.
of cos, I wish to increase feedrate. Otherwise I have to spend more than 6 hours to complete a workpiece(due to thousand lines to run)!
So, as you mentioned, to increase acceleration in mach3? or do I need to adjust servo motor's parameter too?

Thanks again.
Re: high speed problem...
« Reply #3 on: July 27, 2009, 12:45:32 AM »
Probably because you're running a relatively high feedrate, with a relatively low acceleration.  When running in constant velocity mode, something's gotta give, and it's sharp corners.  Either increase acceleration, or decrease feedrate.  I believe using exact stop mode will also cure that, but at a cost....

Regards,
Ray L.

Hi HimyKabibble,
Firstly, thanks for reply.
of cos, I wish to increase feedrate. Otherwise I have to spend more than 6 hours to complete a workpiece(due to thousand lines to run)!
So, as you mentioned, to increase acceleration in mach3? or do I need to adjust servo motor's parameter too?

Thanks again.


You need to try to increase the acceleration in Mach under Config->MotorTuning.  See how far you can go before it starts faulting, or losing position, then back off 20-30%.  If that doesn't get you there, then your only choices are:

1) Reduce feedrate or
2) Live with rounded corners or
3) Use exact stop mode, which will introduce other issues that may be equally unacceptable or
4) Get bigger motors that allow you to increase acceleration

Regards,
Ray L.
Regards,
Ray L.

Offline simpson36

*
  •  1,374 1,374
    • View Profile
Re: high speed problem...
« Reply #4 on: July 27, 2009, 07:19:19 PM »
There is a parameter within CV settings that allows you to set a specific angle where CV will kick out and you will get sharp corners.

Note that I have not used this particular fix and there are numerous things within Mach that do not work exactly as planned, but it's worth a shot since this feature was specifically designed to solve the problem you are having.
Re: high speed problem...
« Reply #5 on: July 28, 2009, 12:16:14 AM »
"exact stop mode" solve my problem. Thanks all.

Offline RICH

*
  • *
  •  7,402 7,402
    • View Profile
Re: high speed problem...
« Reply #6 on: July 28, 2009, 08:34:28 AM »
YMISO,
here is a link to some info on the CV mode in support>documentation above:

http://www.machsupport.com/docs/Mach3_CVSettings_v2.pdf

RICH