Hello Guest it is August 20, 2019, 10:34:33 AM

Author Topic: In constant velocity mode but seems like exact stop!  (Read 3553 times)

0 Members and 1 Guest are viewing this topic.

In constant velocity mode but seems like exact stop!
« on: November 05, 2008, 05:42:26 AM »
Hi,

I'm still finding my way with Mach, and I'm not happy with the smoothness of my machine. It's in CV mode (the button on the screen is highlited green) and I changed the g-code from g61 to g64 but it still has very jerky movement, more noticable at higher speeds.

Is this something in the settings? I think the settings are default as I've only adjusted the motor tuning settings.

Thanks
Splint
Re: In constant velocity mode but seems like exact stop!
« Reply #1 on: November 05, 2008, 06:45:14 AM »
Try turning down the acceleration.

You might have it so high, that the accel and deccel time are to short that it seems like exact stop.

regards
Fernando
Re: In constant velocity mode but seems like exact stop!
« Reply #2 on: November 05, 2008, 07:42:42 AM »
There are issues with mach saving CV changes during a session. Set up CV by setting G64. Also check that the other CV options are off, such as CV distance tolerance, CV feedrate, CV stop on angle, plasma, and G100 adaptive nurbsCV.
These settings are all in general config except for CV feedrate is on the settings screen. Once you have this set close and end you mach session and open mach back up. Check that your settings stuck now it should work. If you make any changes to your CV settings you MUST close mach and reopen.

Which reminds me.

REQUEST: Please put CV FEEDRATE on the general config dialog in the CV options section.
Re: In constant velocity mode but seems like exact stop!
« Reply #3 on: November 06, 2008, 06:11:22 AM »
Thanks Swarfboy, it seems to be working properly now. Thanks also to you Fernando, I'll play around with the acceleration ans see if I can optimise it.

Regards
Splint
Re: In constant velocity mode but seems like exact stop!
« Reply #4 on: July 24, 2009, 07:36:51 PM »
hi im running Version R3.042.029 and my table is acting the same way i have cv checked and all options turned off  and cv feedrate is off   but it seems like it is running in exact stop mode  it seems cv only works when i check the plasma option  the only thing that i havent done is install the G64  im running sheetcam as my gcode generator and over there on the boards it seems like no one has had to do anything with this  any help would be greatly appreciated

John
Re: In constant velocity mode but seems like exact stop!
« Reply #5 on: July 24, 2009, 07:48:12 PM »
ok i think thats my problem the g64    is there anyway to always insert this into mach or will i have to do this in sheetcam

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: In constant velocity mode but seems like exact stop!
« Reply #6 on: July 25, 2009, 02:36:18 AM »
It is best to have it in your code as although you can set the default in Mach to CV if there is a G61 in your code it will change it back the ES.
 To set the default for Mach look on general config page, its in the middle section of that page if I remember correctly.
Hood

Offline simpson36

*
  •  1,374 1,374
    • View Profile
Re: In constant velocity mode but seems like exact stop!
« Reply #7 on: July 27, 2009, 07:14:28 PM »
If your feedrate is high and you are using backlash comp, the motion will 'jerk' whenever the direction changes.

Just something else to check . . .