Hello Guest it is January 19, 2020, 01:51:22 PM

Author Topic: soft limit warning  (Read 7947 times)

0 Members and 1 Guest are viewing this topic.

soft limit warning
« on: July 26, 2009, 02:38:31 PM »
Hey All,

Well after a couple months of my router being down because of a crashed computer (had to reload all my software and new HD) and broken z-axis I am almost back and running. Unfortunately I did not save a copy of all my Mach3 settings so I am starting all over again :-\

This time around I added another switch in series with all the axis for home and limit. Now I cannot get my system to run because I get a "limit switch triggered " error but on the diagnostic screen, none of the switches our triggered?

I have the soft limits set to X-100, Y-100, and Z-200.  I have the unit configured in inches so maybe those have to be smaller values?
I have a couple of screen shots, any ideas what I did not configure correctly?  I watched the Mach3 video tutorial and thought I had everthing correct.
skipper

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: soft limit warning
« Reply #1 on: July 26, 2009, 02:53:01 PM »
That is not a softlimit warning, it is an actual limit switch warning.
Sounds like noise on your switch. Try setting the Debounce Interval to 2000 and see if it helps the problem. If it does then it is best to cure it rather than covering  it up. It is most likely one of two things, first noise which can usually be cured by having shielded cables on the limit switches and having the shield properly grounded at one end and one point for all grounds within your control. The second thing it could be is a bouncy switch, if its that then not much you can do except keeping the debounce interval high or getting better quality switches.
Hood
Re: soft limit warning
« Reply #2 on: July 27, 2009, 02:07:25 AM »
On which Mach 3 screen do I set the debounce interval?

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: soft limit warning
« Reply #3 on: July 27, 2009, 02:09:52 AM »
Config menu then General Config then you will see Debounce Interval top righthand side.
Hood
Re: soft limit warning
« Reply #4 on: July 31, 2009, 12:17:29 AM »
Hi All,

Well I got the limit switch sorted out, the debounce level change help allot.  Now I have another couple of issues.  One is that my Homing is in the direction even though I have Home Neg. selected.  Why?
Also, when I do get my x-axis homing, it will hit the home switch, then back off of it like it is supposed to, but it never moves off the switch enough to turn off the LED. So what happens is that all the homing stops.  Also, the homing speed is dreadfully slow, super slow.  I have attached some screen shots.
According to the Mach3 manual, my 1/4-20 threaded rod I am using as a lead screw is 20 TPI. So, steps per should be 20 x 200 x 8 = 32000. Is this sound correct?  I does not seem to help with the homing speed.

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: soft limit warning
« Reply #5 on: July 31, 2009, 02:41:26 AM »
Your homing problem is due to noise or bouncing switches, you need to get that sorted. Debounce may help but it is only masking the problem, best to get it sorted properly.
If you take the check out of the Home Negative it should home the other way.
 Your steps per unit sound correct presuming you have no gearing between motor and screw.
Hood
Re: soft limit warning
« Reply #6 on: July 31, 2009, 11:45:44 AM »
Excuse me for butting in.  Not trying to highjack the thread, but I have a question on this issue.

I understand that it would be best to correct a noise problem rather than cover it up with a high debounce value.  However, if the problem is infrequent and setting a debounce value corrects the problem, is that a "reasonable" way to deal with it?  If yes, what would be considered a "reasonable" debounce value?

Regarding debounce, what is the downside of setting the debounce value too high (aside from covering up a known problem)?
Bill (the Cat) Shubert
Re: soft limit warning
« Reply #7 on: July 31, 2009, 11:55:19 AM »
For the "bouncing switches" do I get better quality switches or use sheilded cable?  I think I got the switches from radio shack for a couple of dollars each.
Should homing speed be very slow or just reasonalbly slow.  It takes forever to home my y-axis at the current homing speed.

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: soft limit warning
« Reply #8 on: July 31, 2009, 01:31:52 PM »
However, if the problem is infrequent and setting a debounce value corrects the problem, is that a "reasonable" way to deal with it?  If yes, what would be considered a "reasonable" debounce value?

Regarding debounce, what is the downside of setting the debounce value too high (aside from covering up a known problem)?

Personally I would try and get things better, all of my machines had zero for the debounce. They all have the SmooothStepper now so normal Debounce doesnt work, it is set in the plugin.
Debounce just means that Mach will wait until it sees a signal  that is as long or longer than the debounce time set before it will act on it.

For the "bouncing switches" do I get better quality switches or use sheilded cable?  I think I got the switches from radio shack for a couple of dollars each.
Should homing speed be very slow or just reasonalbly slow.  It takes forever to home my y-axis at the current homing speed.



Limit switches wiring should be shielded and properly grounded or you are asking for trouble and also quality switches are best if you want to avoid problems. I would certainly advise you to try shielding first.
Homing speed is set as a % of rapid speed, you will find it from Config menu then Homing and Limits.
Hood