Hello Guest it is February 27, 2021, 11:25:53 PM

Author Topic: What causes '. . . out of limits to use soft limits' error?  (Read 4289 times)

0 Members and 1 Guest are viewing this topic.

Offline simpson36

*
  •  1,369 1,369
    • View Profile

Message similar to subject line every time I try to click soft limits on.  >:(  Been this way for a while so I don't remeber exactly when it started or what I might have changed just prior.

Homing works fine, all limit switches funtioning, machine is well within the homing/limits settings, with no limit switches triggered.

I tried disabling one axis at a time and then disabled all of them together . . .  same error  ???

Same error with Gcode loded or with no program loaded. Machine is running fine.

So it is not something glaringly obvious. Got me stumped . . . prolly something simple I am overlooking.  :-[


Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: What causes '. . . out of limits to use soft limits' error?
« Reply #1 on: July 22, 2009, 03:02:16 PM »
A axis? Setting for that is on General Config page.
If not, then what do you have X and Y min and Z Max Soft Limits set to and which position is the table in when homed?
Hood

Offline simpson36

*
  •  1,369 1,369
    • View Profile
Re: What causes '. . . out of limits to use soft limits' error?
« Reply #2 on: July 22, 2009, 04:56:00 PM »
It does this whether the A axis is active or not, so we can take that out of the picture. 

The machine homes all three axis to zero and goes positive from there in X and Y and negative in Z.
Clicking on RefAllHome works perfectly

I had the X axis converted to a photointerruptor for a while and I recently converter the Y and Z as well. Each axis limit switch is wired to its own pin.  Hmmmm, now come to think of it, that IS a change that was made  . . . I really can;t say if the error coinsided with the limit switch upgrades.

Does it make a difference if the limits are separated or on the same pin?


It is set something like this

Axis  MAX      MIN

X     9.8       0

Y     5.7       0

Z      0        -12.5


Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: What causes '. . . out of limits to use soft limits' error?
« Reply #3 on: July 22, 2009, 05:25:20 PM »
Using different pins wont hurt, thats the way my Bridgeport is set up.
All sounds fine so dont know where your problem lies, if you want to attach your xml I will have a look and see if I can find a problem.
Hood

Offline simpson36

*
  •  1,369 1,369
    • View Profile
Re: What causes '. . . out of limits to use soft limits' error?
« Reply #4 on: July 22, 2009, 05:55:45 PM »
Got it figured out.

Can't use more than a 30 bit number for limits. I had stupid huge numbers still in the A axis from the time before you enlightened me to the joys of SwapAxis.

Doesn't matter if A is active or not. Mach just pukes on the huge number if its there.

Thanks for the help, though. I owe you an Atholl Brose

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: What causes '. . . out of limits to use soft limits' error?
« Reply #5 on: July 22, 2009, 05:59:13 PM »
LOL, will pass on that but thanks anyway :D
Hood