Hello Guest it is November 19, 2019, 03:53:39 AM

Author Topic: mach3 bahaves badly  (Read 3498 times)

0 Members and 1 Guest are viewing this topic.

Offline Robhi

*
  •  138 138
    • View Profile
mach3 bahaves badly
« on: September 06, 2009, 03:36:03 PM »
hello,
 I have some problem when turning wood with my mach3..

I programme M piecework with maystercam design, sometimes I use circle to get some kind of shapes to make my piecework.. then I delete the half of the circle for example.etc... but the problem is mach3 sees always the circle but not as arcs, and once it cuts completely my piecework.

anybody know where the problem is?
thanks Robhi

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: mach3 bahaves badly
« Reply #1 on: September 06, 2009, 05:50:53 PM »
Can you post a screenshot of the toolpath, could be a few things, first is your IJ mode, second could be reversed arcs in front toolpost and possibly even you need a G2 rather than a G3 or vice versa.

Hood

Offline Robhi

*
  •  138 138
    • View Profile
Re: mach3 bahaves badly
« Reply #2 on: September 07, 2009, 03:11:36 PM »
Hello, thanks for replying..

Here is a screenshot as well as a copy of mach3 turn XML.
But I have know idea about:-
Robhi
Can you post a screenshot of the toolpath, could be a few things, first is your IJ
mode, second could be reversed arcs in front toolpost and possibly even you need a
G2 rather than a G3 or vice versa.

Hood

Thanks again
Robhi

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: mach3 bahaves badly
« Reply #3 on: September 07, 2009, 03:51:40 PM »
can you also post your code please.
Hood

Offline Robhi

*
  •  138 138
    • View Profile
Re: mach3 bahaves badly
« Reply #4 on: September 08, 2009, 02:22:37 PM »
Hello,
attached is the file of the workpiece.
Thanks
Robhi

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: mach3 bahaves badly
« Reply #5 on: September 08, 2009, 02:39:29 PM »
Config menu, Ports and Pins, Turn Options and take the check out of Reversed Arcs in Front  Toolpost and see it it looks right.
Hood

Offline Robhi

*
  •  138 138
    • View Profile
Re: mach3 bahaves badly
« Reply #6 on: September 08, 2009, 04:12:43 PM »
hello,
Thanks Hood, I will try as you said and let you of course.

thanks
Robhi

Offline Robhi

*
  •  138 138
    • View Profile
Re: mach3 bahaves badly
« Reply #7 on: September 10, 2009, 12:37:08 PM »
hello,
Thank you too much for your help, everything is OK..
Thanks Hood and all of you.
Robhi

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: mach3 bahaves badly
« Reply #8 on: September 10, 2009, 01:14:57 PM »
:)

Hood