Hello Guest it is July 05, 2020, 10:27:17 PM

Author Topic: Thing ran fine, now jogging skips?  (Read 2314 times)

0 Members and 1 Guest are viewing this topic.

Thing ran fine, now jogging skips?
« on: June 01, 2009, 07:39:09 PM »
Hi everyone. My Zenbot was fine for two months. In the last 2 weeks the Z axis was fluttering terribly when I tried to jog with xbox 360 controller.I checking the belts and bolts and everything mechanical, nothing out of place. I switched the cables from the driver to the steppers and found the z axis stepper worked fine when plugged into the x axis cable.  I then checked  in the motor configs, the z was different than the other two axes so I changed it and it ran flawlessly. Thought it was fixed, then after a few days, the x axis started doing the same thing. This time, I don't see anything off in the motor configs, and after shutting everything down, restarting, I can't get it working.
 I would just like to know, what would make the machine just go from working fine to this?

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: Thing ran fine, now jogging skips?
« Reply #1 on: June 03, 2009, 05:41:49 AM »
Hard to say, could be corrupt software or even you installed some new software that is making a mess of things, more likely however could be some bad connections or hardware problem.
 Is it a licenced copy of Mach? What version are you running?
If you attach your xml I will have a look and see if I can find a problem there.
Hood
Re: Thing ran fine, now jogging skips?
« Reply #2 on: December 05, 2009, 10:17:37 AM »
The problem was in the driver. Mechatronics products can be good, but probably not as secure as Gecko. I don't know what fixed it, but I changed some chips, and adjusted the current with the little phillips head adjustment deals in the driver and it was good.