Hello Guest it is October 17, 2021, 10:46:37 PM

Author Topic: Settings problem  (Read 2560 times)

0 Members and 1 Guest are viewing this topic.

Settings problem
« on: May 26, 2009, 04:06:44 PM »
What controls the motor speed when using:-
Settings
Steps per unit
How much would you like to move?
" I put a value in"
click OK
and the motors go "like a bat out of hell"
Smiley
Brian.

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: Settings problem
« Reply #1 on: May 26, 2009, 05:04:23 PM »
Are you meaning in the Set Steps per unit utility? If so then it moves at full rapid which is whatever you have the velocity in motor tuning set to.
Hood

Offline jimpinder

*
  •  1,232 1,232
  • Wakefield, West Yorks, UK
    • View Profile
Re: Settings problem
« Reply #2 on: May 27, 2009, 04:12:50 AM »
Config/Motor Tuning/Steps per unit has nothing to do with the speed of your motors. This is the number of pulses the motor requires to move a set distance (either 1 mm or 1 inch) on your system. Unless you have this correct your machine will not be accurate. Depending on your set up this will be a figure between 800 and 1500 for steps per mm, or 20,000 to 60,000 steps per inch. If you do not know how to set this, come back and we will explain.

Once you have accurately set the steps per inch or mm, then you can set the maximum motor speed, which again will vary depending on your set up. Basically you move the motors slowly, and then gradually speed up until you have the maximum speed combined with accuracy. You can then do the same with the acceleration.

What are you trying to do exactly.
Not me driving the engine - I'm better looking.