Hello Guest it is October 16, 2019, 06:50:56 PM

Author Topic: Tool pauses at X axis while cutting circles or threading?  (Read 8855 times)

0 Members and 1 Guest are viewing this topic.

Re: Tool pauses at X axis while cutting circles or threading?
« Reply #10 on: May 24, 2009, 10:37:40 AM »
No backlash comp is not on, I didn't think that a smoothstepper board supported this?

I'll check on the CV mode today (I think it is, but will check again)...

Offline ger21

*
  • *
  •  6,288 6,288
    • View Profile
    • The CNC Woodworker
Re: Tool pauses at X axis while cutting circles or threading?
« Reply #11 on: May 24, 2009, 10:49:22 AM »
You never said you were using a SS. :)
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html
Re: Tool pauses at X axis while cutting circles or threading?
« Reply #12 on: May 24, 2009, 02:09:48 PM »
Your right I didn't mention that.

I just checked and it is in CV mode.

The problem is occurring when the circle cut crosses the X axis so the Y axis isn't changing directions at this point and shouldn't be the problem.

Offline ger21

*
  • *
  •  6,288 6,288
    • View Profile
    • The CNC Woodworker
Re: Tool pauses at X axis while cutting circles or threading?
« Reply #13 on: May 24, 2009, 03:11:19 PM »
Leave CV on, but turn off Distance and Feedrate on the settings page and uncheck all the options in General Config.
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html
Re: Tool pauses at X axis while cutting circles or threading?
« Reply #14 on: May 24, 2009, 04:19:16 PM »
thanks I'll give it a try in about 60 secs, running a part right now
Re: Tool pauses at X axis while cutting circles or threading?
« Reply #15 on: May 24, 2009, 04:35:36 PM »
Distance and feedrate were unchecked on the settings tab.  I cleared out the two options checked below under CV control and it still pauses as it crosses the X axis?  Now what? 

Re: Tool pauses at X axis while cutting circles or threading?
« Reply #16 on: May 24, 2009, 04:48:25 PM »
You have the Exact Stop checked!
Check the Constant Velocity instead. Make sure you don't have any G61 in your g-code.
Re: Tool pauses at X axis while cutting circles or threading?
« Reply #17 on: May 24, 2009, 04:53:00 PM »
What is the feed rate setting under the settings tab? And is it active?
« Last Edit: May 24, 2009, 04:56:26 PM by SteinarN »
Re: Tool pauses at X axis while cutting circles or threading?
« Reply #18 on: May 24, 2009, 05:14:15 PM »
Not sure why?  I just went in and looked again and it is on CV (not Exact), I could of swore it was before as well???  No G61 is used in the code I'm running.  Here's what the settings tab looks like...  I'll try running it again and see what happens...

Re: Tool pauses at X axis while cutting circles or threading?
« Reply #19 on: May 24, 2009, 05:22:33 PM »
Well it's working fine now.  Somehow I got on Exact stop mode???  Will this setting change based upon a command in gcode?  I'm guessing one of my other programs is doing this...