Hello Guest it is October 23, 2019, 12:40:15 PM

Author Topic: Can't get Mach Nation to work  (Read 11414 times)

0 Members and 1 Guest are viewing this topic.

Can't get Mach Nation to work
« on: April 10, 2009, 02:40:09 PM »
I'm having trouble getting the Mach Nation screen set to work.  Here's what I've done since
starting try to figure out why is doesn't work for me:

1) Installed current Mach release in a new directory.
2) Deleted old flash.dll and copied new flash.dll into plugins directory
3) Installed and reinstalled latest flash plugin
4) Verified that flash plugin is enabled in Mach config.

A screenshot of the result in Mach is attached.  The DRO's can be typed in, but the buttons don't work.

I can open "Mach Nation 11-20.swf" in firefox and it looks fine and the screen buttons work.

Any suggestions?

Thanks in advance.

Offline zealous

*
  •  492 492
  • HI!
    • View Profile
    • Artsoft Solutions
Re: Can't get Mach Nation to work
« Reply #1 on: April 11, 2009, 03:50:37 AM »
Hi hdscarbro,
Can you try downloading http://www.microsoft.com/downloads/details.aspx?FamilyId=262D25E3-F589-4842-8157-034D1E7CF3A3&displaylang=en and let me know if this resolves the issue.
« Last Edit: April 11, 2009, 03:54:41 AM by zealous »
Re: Can't get Mach Nation to work
« Reply #2 on: April 13, 2009, 08:36:58 AM »
Hi Jason,

This didn't help.  I've also run windows update.  The machine has been updated to SP3.

David

Offline zealous

*
  •  492 492
  • HI!
    • View Profile
    • Artsoft Solutions
Re: Can't get Mach Nation to work
« Reply #3 on: April 13, 2009, 12:55:23 PM »
it looks like a missing font on your system. Mach Nation uses Arial....I've PM'ed you test file.
Re: Can't get Mach Nation to work
« Reply #4 on: April 14, 2009, 12:31:12 PM »
The Arial font is available.  I can access it in WordPad.

If you look at the screen capture jpg in my first post, the text "Tool:0" appears to be Arial.

The Mach Nation swf file looks and works fine when opened via Firefox on the same system?  When opened in Firefox the "change screen" buttons work, but in Mach, they don't.

Offline ger21

*
  • *
  •  6,288 6,288
    • View Profile
    • The CNC Woodworker
Re: Can't get Mach Nation to work
« Reply #5 on: April 14, 2009, 01:37:18 PM »
Do you have the latest Flash plugin?
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html
Re: Can't get Mach Nation to work
« Reply #6 on: April 14, 2009, 02:48:49 PM »
The latest Flash plugin is installed.

I installed "Flash CS3 Professsional" on the machine and the problem went away.  Now "Mach Nation" works fine.

Offline zealous

*
  •  492 492
  • HI!
    • View Profile
    • Artsoft Solutions
Re: Can't get Mach Nation to work
« Reply #7 on: April 14, 2009, 08:48:55 PM »
Hi,
Yes the "ActiveX Flash Player 9" is what you need...shouldnt need anything else...this is diffrent then the web browser plug'in.
Re: Can't get Mach Nation to work
« Reply #8 on: April 15, 2009, 09:43:11 AM »
Ah.  I had to get an old flash plugin.  The "sticky" post at the top of this forum points to the current flash plugin (version 10) which did not work for me.

Here's where to get archived versions of old flash plugins:
http://kb.adobe.com/selfservice/viewContent.do?externalId=tn_14266&sliceId=2

I uninstalled all of the flash stuff (Version 10 plugin, CS3, etc.) and ran the standalone Adobe flash uninstaller on my "Mach" machine.

After installing flash from the 9r124 folder in the downloaded archive, Mach Nation works.   Whew.

Offline zealous

*
  •  492 492
  • HI!
    • View Profile
    • Artsoft Solutions
Re: Can't get Mach Nation to work
« Reply #9 on: April 15, 2009, 10:03:42 AM »
weird...I'll have to check into that...I know you have to "publish" as AS2 Flash 8 but it should work in any player....BTW I am hoping we will have AS3 working with Mach soon.