Hello Guest it is June 18, 2019, 03:46:59 AM

Author Topic: Spindle speed syntax error  (Read 4700 times)

0 Members and 1 Guest are viewing this topic.

Offline Greolt

*
  •  956 956
    • View Profile
Spindle speed syntax error
« on: March 27, 2009, 04:51:52 AM »
For a little while I have been getting strange behaviour of my spindle speed control.

Thought it must be a glitch in my electronics.

The symptom I have had is, the gcode sets the rpm.  The DRO updates as it should..

But the actual RPM is whatever was last used.  Until I nudge the override, then it goes to the correct rpm.

However I have discovered there is some problem with the spindlespeed.m1s

Here is the line.  As far as I know this is Mach standard issue,

rpm = GetRPM() SetSpinSpeed( rpm )

The VB editor does not like it.  Calls a syntax error on "SetSpinSpeed"

Version R3.042.022

Greg

Offline Hood

*
  •  25,844 25,844
  • Carnoustie, Scotland
    • View Profile
Re: Spindle speed syntax error
« Reply #1 on: March 27, 2009, 04:58:26 AM »
Are they on the same line in the macro? Think they should be on different lines, ie
rpm = GetRPM()
SetSpinSpeed( rpm )


Hood

Offline Greolt

*
  •  956 956
    • View Profile
Re: Spindle speed syntax error
« Reply #2 on: March 27, 2009, 05:37:10 AM »
Yes you are spot on Hood.  That fixed it.

Funny thing is I have Mach loaded on three computers and every one of them in every profile had it on one line.

How did that happen?  Must have ghosts in the house or something.

I certainly did not do it.

Thanks,  Greg

Offline Hood

*
  •  25,844 25,844
  • Carnoustie, Scotland
    • View Profile
Re: Spindle speed syntax error
« Reply #3 on: March 27, 2009, 05:42:49 AM »
Weird, maybe I better look at mine LOL

Hood

Offline Hood

*
  •  25,844 25,844
  • Carnoustie, Scotland
    • View Profile
Re: Spindle speed syntax error
« Reply #4 on: March 27, 2009, 05:47:10 AM »
Just looked and mine are all OK, maybe you do sleep typing instead of walking ;D

Hood

Offline smurph

*
  • *
  •  1,094 1,094
  • "That there... that's an RV."
    • View Profile
Re: Spindle speed syntax error
« Reply #5 on: March 27, 2009, 10:51:07 PM »
In BASIC, you use a colon to separate multiple commands on one line.  You might look for the magical colon on your other three machines.  Or try it.  I have no idea if it even pertains to the VB in Mach.

Steve
Re: Spindle speed syntax error
« Reply #6 on: March 27, 2009, 11:06:28 PM »
Just checked mine out of curiosity.
RC

Offline Greolt

*
  •  956 956
    • View Profile
Re: Spindle speed syntax error
« Reply #7 on: March 27, 2009, 11:25:32 PM »
Hah!!!!  I am not going mad after all.  ;D

What would do that?

Greg
Re: Spindle speed syntax error
« Reply #8 on: March 28, 2009, 12:27:37 AM »
I haven't a clue Greg.
This is on my office PC and only used for sim.
 
RC