Hello Guest it is October 19, 2019, 01:55:40 PM

Author Topic: Stop Mach from ignoring limits when homing  (Read 7943 times)

0 Members and 1 Guest are viewing this topic.

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Stop Mach from ignoring limits when homing
« Reply #10 on: March 24, 2009, 08:18:36 AM »
Greg just tried it by simulating the home switches and Mach just ignores the home move for the axis that is active but will home the rest (assuming they are inactive) It doesnt seem to move the opposite way.
Hood
Re: Stop Mach from ignoring limits when homing
« Reply #11 on: March 24, 2009, 08:21:08 AM »
Thanks for the input guys.  I agree, it's always best to make sure you're on the proper side of the home switch before homing, but on this machine, the x-travel is only ~4.5" and the home switch is closer to the center of travel than the end; i.e. not always obvious if you're slightly to the wrong side of home.

I like you're idea greolt, unfortunately, Hardinge had a way of cramming an obscene amount of mechanics/electronics in very small spaces.  Not to mention the fact that the mechanism that trips the home switch (and limit switches) on the x-axis is very elaborate and I'd rather not modify it to hold the home switch on if you're on the wrong side.  On an easier machine, definitely the way to go I would say though.

I wrote up a quick Brain to monitor the limit switches and trip a stop if it sees one.  I didn't figure Mach would be monitoring the limit inputs at all (the LEDs don't light on the diagnostic screen when you come on a limit and you're homing) but the brain does seem to trip the estop still.

Thanks again, hopefully this will work!
-Ryan

Offline Greolt

*
  •  956 956
    • View Profile
Re: Stop Mach from ignoring limits when homing
« Reply #12 on: March 24, 2009, 10:07:26 AM »
Greg, thats the way I have the home switches now, didnt know that Mach would move the opposite direction if it was active, however that may not give you an accurate home unless it actually moves the wrong way until the switch is inactive then goes back onto it for the actual homing move, does it do that?



No it just moves off the switch.  And that is probably the same accuracy anyway. 

However I tend to home again.  Resulting in a very small move, on and off the switch.

Greg
« Last Edit: March 24, 2009, 10:12:35 AM by Greolt »

Offline Greolt

*
  •  956 956
    • View Profile
Re: Stop Mach from ignoring limits when homing
« Reply #13 on: March 24, 2009, 10:09:39 AM »
Greg just tried it by simulating the home switches and Mach just ignores the home move for the axis that is active but will home the rest (assuming they are inactive) It doesnt seem to move the opposite way.
Hood

You need to uncheck "Home Sw Safety" on the config page.

Greg

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Stop Mach from ignoring limits when homing
« Reply #14 on: March 24, 2009, 10:10:28 AM »
ah ok thanks, will test it out, can never have enough knowledge :)
Hood

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Stop Mach from ignoring limits when homing
« Reply #15 on: March 24, 2009, 10:11:25 AM »
Yep works a dream :)
Hood