Hello Guest it is November 21, 2019, 02:10:36 PM

Author Topic: Digitize wizard not saving to file properly  (Read 2172 times)

0 Members and 1 Guest are viewing this topic.

Digitize wizard not saving to file properly
« on: March 13, 2009, 07:32:20 PM »
Hello,

I am having problems with the digitizing wizard. When the wizard starts, it prompts me to provide a filename. It then goes about gathering the point cloud. During the digitizing procedure, however, the limit switches will occasionally go off without being pushed. When the gcode stops running, not all of the points will have been written to file.

For example, I started running the wizard at 1 PM today. At about 1:30, the limit switch went off. I reset the switch and continued scanning. At 3:30, the scan finished. However, the file did not include all of the points. It was last modified at 2:00, which means that it recorded _some_ values after the limit switch was triggered, but not all of them. Has anyone had this problem before?

Thanks,
Kyle

Offline ger21

*
  • *
  •  6,288 6,288
    • View Profile
    • The CNC Woodworker
Re: Digitize wizard not saving to file properly
« Reply #1 on: March 13, 2009, 07:49:58 PM »
I'd guess that the problem is you're switches tripping. You need to fix that first.
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html
Re: Digitize wizard not saving to file properly
« Reply #2 on: March 13, 2009, 08:00:22 PM »
I'd guess that the problem is you're switches tripping. You need to fix that first.

When Mach3 stops due to the limit switch, the mill is not even close to any of the limit switches. I'm pretty sure that the switches are tripping because of noise in the wires. Right now, due to the small number of inputs on my breakout board, I have all the switches wired in series (normally closed) and connected to a single input. As a result, there is a long (unshielded) wire running between all of the switches.... lots of room to pick up interference.

I've got a breakout board, PCI parallel port card, and shielded 2-conductor wire on order so that I can connect each switch to a unique input. Hopefully this will either (a) stop the problem entirely, or (b) let me figure out which limit switch keeps tripping.

Does anyone know if the limit switches could be the cause of the problem? As I said earlier, the wizard saves some data points after the limit switch is tripped, but not all of them.

Kyle
Re: Digitize wizard not saving to file properly
« Reply #3 on: March 18, 2009, 03:25:12 PM »
I've switched to using shielded cables with 1 uF capacitors from the input signals to ground, and this seems to have stopped the problem with the limit switches accidentally going off.

The digitizing wizard is now recording to file properly. Thanks for the help!  ;D

Kyle