Hello Guest it is October 23, 2019, 01:45:06 AM

Author Topic: Very weird crash/problem  (Read 1774 times)

0 Members and 1 Guest are viewing this topic.

Very weird crash/problem
« on: March 11, 2009, 06:19:46 PM »
Hello,

I was happily cutting out a part on my router earlier this evening when, at the very end of a job, instead of retracing the z axis drove straight down in the table. Thanks to the fact that fitting limit switches is still on my list of things to do, some horrible noises were emitted by my machine before I made it to the estop button. Fortunately no damage appears to have been done, but on resetting my servo drivers (UHUs) and manually retracting the z axis by rotating the lead screw by hand (and pliers), I found that if I attempted to jog the z axis up it would instead go down! Jogging down also sent the z axis down - i.e. irrespective of the direction I attempted to jog the axis moved down. At this point I figured maybe the z-axis direction lead had become disconnected from my break out board, but this didn't appear to be the case and my multimeter seemed to agree. I figured I'd restart the computer before trying anything else. I did this, started mach3 and tried jogging the z axis. It worked fine, going up and down as expected.

So, it looks like I experienced some kind of weird software failure, not a hardware problem. Does anyone have any idea why, and how to make sure it doesn't happen again? Obviously the part was written off, and I could have been left with lots of repair work on my router, so I want to make sure all's well before I continue.

Any suggestions or comments gratefully received!

Offline jimpinder

*
  •  1,233 1,233
  • Wakefield, West Yorks, UK
    • View Profile
Re: Very weird crash/problem
« Reply #1 on: March 12, 2009, 02:56:23 PM »
You do not say what output from the computer you are using - LPT1. smooth stepper or what.

I will agree that it would appear that the dir lead on your z axis has failed - and I assume you could test and find out if it had failed high, or failed low. You do not say what breakout board you are using, and whether or not this inverts the voltages from the computer output. What pin do you use for the Z dir lead.

The fact that this rectified itself when you restarted the computer means that the chip set in the LPT1 was also restarted, and so it could have been just a blip in the software, a blip in the LPT1 chipset, or a blip in the breakout board.

I don't see a way of testing, unless you run the program again without a tool in, and see if it re-occurs. Even if it does, you will have a bit of a time tracing it unless for instance you G Code has been currupted and the machine is reading a - command instead of a +.
Not me driving the engine - I'm better looking.