Hello Guest it is October 31, 2020, 09:17:34 PM

Author Topic: Can't get any response from parallel port  (Read 7298 times)

0 Members and 1 Guest are viewing this topic.

Can't get any response from parallel port
« on: February 12, 2009, 03:42:29 PM »
I can't seem to get Mach3 to interact with the parallel port on my computer. I checked in the device manager, and I have the address correct (378).  I couldn't seem to get my motors to respond, so I tried setting up an input switch as shown here http://solsylva.com/cnc/xylotex.shtml . However, triggering the switch shows no activity on the diagnostics, and using the auto-detect for setting up an input switch doesn't detect the switch when pressed. I just switched over from EMC, and the setup worked previously, so I'm not sure what the problem might be. Any ideas what I can do to troubleshoot this?
Re: Can't get any response from parallel port
« Reply #1 on: February 15, 2009, 10:31:50 AM »
Good catch on the port address.  The only other gotcha I can think of off the top of my head is your pin assignments.  Under "Config | Ports and Pins" check your 'Motor Outputs' to verify your step and direction pins are correct (for xylo boards, the default is incorrect) and also check the ins to verify the software is looking for an active low (if your test switch closes a path to ground).  If you get the switch to work but the motors still won't jog, check the "Mptor tuning" section under "Config".  Using the Pacific Sci steppers I bought with my Taig kit, I needed to set 'Steps per' to 16000 (20 in/min for velocity should do for testing).

Actually, there is one more HUGE gotcha that springs to mind.  Art is righteously concerned with industrial safety and wants to be certain all of his customers acknowledge the imperative. To this end, if you don't have a physical E-Stop switch wired into the circut, you will need to set up the software to bypass the default settings.  To do this, go to "Config | Ports and Pins | Input Signals" menu and drop down the list by two 'pages'.  Find the 'E-Stop' line.  I don't know what the optimal setting for this should be, but I find turning all the red Xes into green checks seems to work pretty well.

Good luck!
-K

Offline Tweakie.CNC

*
  • *
  •  8,525 8,525
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Can't get any response from parallel port
« Reply #2 on: February 16, 2009, 07:56:56 AM »
A stand alone monitor for the parallel port called 'Parmon' can be downloaded from here :-

http://www.geekhideout.com/parmon.shtml

With this you can see which pins are switched or activated by Mach.

Tweakie.
KEEP SAFE !
Re: Can't get any response from parallel port
« Reply #3 on: February 17, 2009, 02:23:23 PM »
Ok, using the port monitor I can see my switches are in fact causing the input pin to go high, but Mach3 never seems to get the signal. Likewise, jogging shows no activity on the parallel port in the port monitor. I've verified that Mach3 is using the same address as the port monitor. I still can't get the input auto-detect to detect my switches. Any other thoughts as to what might be keeping mach3 from communicating with the parallel port?
Re: Can't get any response from parallel port
« Reply #4 on: February 17, 2009, 05:21:52 PM »
It turns out I had the wrong port number selected (0 instead of 1). I would had figured that the diagnostics page would show pin status regardless as long as it had the right parallel port address, but apparently not. At any rate, I seem to have controls working now.