Hello Guest it is November 21, 2019, 10:02:51 PM

Author Topic: laptop use  (Read 2537 times)

0 Members and 1 Guest are viewing this topic.

laptop use
« on: February 22, 2009, 12:09:34 PM »
I notice on the downloads page that there is now a statement saying laptops are not supported unless they have an external motion controller.

I have been running my Mach3 on a laptop for some time now using version 2.63. I always have the power cord connected so the laptop is not reliant on batteries. It always works OK. Sometimes I forget to switch the power socket on and it runs on batteries and it is only when the screen goes dark .... or worse blank..... under the power saving routine that I realise the power socket is off ...... and it still continues to operate. I switch the power on smartish though!

So why is the restriction now introduced on laptops?

Are the modern (last couple of years) model of laptops more prone to the power saving problems inferred by the reference to the chip set made in the statement?

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: laptop use
« Reply #1 on: February 22, 2009, 12:33:51 PM »
Laptops have always been a hit or miss , newer ones with all their power management can be even worse.
On the forum you will still get help if you are using a laptop but just if everything has been tried to get it working with Mach then there are no grounds for complaining,  like has occasionally happened in the past, as people said they were unaware that laptops may not work.
Hood

Offline simpson36

*
  •  1,374 1,374
    • View Profile
Re: laptop use
« Reply #2 on: March 27, 2009, 04:23:31 PM »
FWIW, I used a laptop for quite a while.

The power saving feature is the problem . . . even if it is running off the wall current. On my laptop, all power saving features could be disabled in the bios. Once done, no more problems, but the 1.2ghz VIA processor would occationally peg and then the motors could stall.  I figure that the VIA CPU is not good with with math functions.

I'm running now of a really old dual P3 server. I set the Mach 3 process to 'real time' priority for one of the CPUs. Works great and never gets close to pegging the 850Mhz Intel processor.