Hello Guest it is October 15, 2019, 10:16:37 AM

Author Topic: mach e stop  (Read 8084 times)

0 Members and 1 Guest are viewing this topic.

Offline greg

*
  •  66 66
    • View Profile
Re: mach e stop
« Reply #10 on: January 07, 2009, 04:08:59 PM »
in ports & pins i have turned off the limits. i will try assigning a pin # to e stop. i will let you know what happens. thanks greg

Offline greg

*
  •  66 66
    • View Profile
Re: mach e stop
« Reply #11 on: January 07, 2009, 04:17:04 PM »
i assigned pot 1 pin 11 & the reset still flashes with it set both high & low. anyother ideas? thanks greg
Re: mach e stop
« Reply #12 on: January 07, 2009, 04:19:28 PM »
Just to be sure.....You are clicking on the RESET button after every change you make....right ?

Offline greg

*
  •  66 66
    • View Profile
Re: mach e stop
« Reply #13 on: January 07, 2009, 04:29:16 PM »
yes i am. then the window opens saying a limit is tripped or e stop is active. then i go back into ports & pins. if i had turned it off before it is back on again. thanks greg

Offline greg

*
  •  66 66
    • View Profile
Re: mach e stop
« Reply #14 on: January 07, 2009, 05:09:12 PM »
overloaded
if you can not turn it off how do you use mach if you are new & just trying the demo? thanks greg

Offline Hood

*
  •  25,855 25,855
  • Carnoustie, Scotland
    • View Profile
Re: mach e stop
« Reply #15 on: January 07, 2009, 05:12:34 PM »
You can turn it off normally by setting it to port 0 pin 0 but you cant physically disable the E-Stop. You can also have pins asigned and just have the  active state set the right way and that will do the same.
 You obviously have something wrong that you are not able to do that, if you attach your xml I will have a look and see if its any of your settings, if not then maybe a reinstal of Mach would sort it.
Hood

Offline greg

*
  •  66 66
    • View Profile
Re: mach e stop
« Reply #16 on: January 07, 2009, 06:35:54 PM »
here is the xml. any & all help is appreciated. thanks greg

Offline Hood

*
  •  25,855 25,855
  • Carnoustie, Scotland
    • View Profile
Re: mach e stop
« Reply #17 on: January 07, 2009, 07:11:42 PM »
Greg its your software limits, press the SoftLimits button to off and see if that helps.
Hood

Offline greg

*
  •  66 66
    • View Profile
Re: mach e stop
« Reply #18 on: January 07, 2009, 08:41:44 PM »
thanks hood
i can not try it for aprox 12-14 hours then i will let you know. thanks greg

Offline greg

*
  •  66 66
    • View Profile
Re: mach e stop
« Reply #19 on: January 08, 2009, 10:24:21 AM »
hood
that fixed it!!  thanks for everyones help [especially yours]. greg