Hello Guest it is August 07, 2022, 09:26:59 PM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - kcrouch

Pages: « 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 »
161
Robert,
Your choice will depend mostly on what tou can locate for an interconnect board. For the 2143 you can use an ICM-20100 which is relatively inexpensive even new. The 1842 will need an ICM-1900 which is pricier new, but probably more easily available used. The 1842 will also have analog inputs, which are nice, but not necessary for most people. My personal choice is the 21x3 series with a RIO connected via Modbus to handle extra I/O both digital and analog.
Kenny

162
Robert,

The latest versions of the plugin will recognize your controller and use the appropriate communication mode. No worries. Just be sure to use the latest firmware for your board and the latest drivers from SmartTerm and you should have no problems wih communication speed. I have both boards here and they work fine with the new plugins.

If Mach is happy with your g-codes, the new plugins will be happy too.

Kenny

163
Galil / Re: Mach as motion control Galil RIO as I/O
« on: May 14, 2009, 02:56:58 PM »
Scott,
I know that it seems strange, but, that is what it took to get everything talking. Believe it or not, the RIO always uses 0 as the starting address for that screen to make everything happy. I can't offer any explanation, I am only conveying what it took to get it working well. It is definitely not like what I had to do for the DL-05, or Arturos ethernet board.
Go figure!

Thanks,
Kenny

164
Galil / Re: Mach as motion control Galil RIO as I/O
« on: May 14, 2009, 10:09:27 AM »
Here is the manual for using the RIO with Mach.
Cheers,'Kenny

165
Galil / Re: DMC 1425 minor issue, I hope
« on: May 11, 2009, 04:55:31 PM »
Doc,
If you are having trouble, just send the .xml to my e-mail. The ethernet is way faster than the serial, and we need fast communication to get everyone working together.
Good luck!
Kenny

166
Galil / Re: DMC 1425 minor issue, I hope
« on: May 11, 2009, 04:45:14 PM »
Doc,
For starters, serial is woefully inadequate for this project. Get an ethernet crossover cable and configure the system to use the ethernet communication. When you have done that, if you are still having trouble, please send my a copy of your .XML file from Mach3 so that I can look further into this. There is no way that the serial port will give anywhere near acceptable performance for Mach.
Kenny

167
Galil / Re: DMC 1425 minor issue, I hope
« on: May 11, 2009, 10:20:46 AM »
Doc,
Please provide us with the version # of the plugin, and the current settings that you have setup for it. It would be most helpful if you could send a copy of your .XML file so that I can check it out. We aren't sure about the 1425, but I have one and can set it up to test.
Thanks,
Kenny

168
Galil / Re: Mach3 + Galil
« on: May 09, 2009, 09:37:39 AM »
Velly,
This is your lucky day. I am attaching the instructions for the RIO 47100 to this message. You do not need the Galil plugin for the RIO, as I have it worked out using ethernet Modbus. Good luck!
Kenny

169
Galil / Re: Mach3 + Galil
« on: May 02, 2009, 08:45:24 AM »
sivaraj,

The analog inputs are currently not supported by the plugin, although we are working on them. I have just finished implementing

the Galil RIO with Mach, So you could use one of those if you have one. We will use what we learned from the RIO to get the

analog inputs functioning fairly soon.

Will post here when it is ready.

Kenny

170
Galil / Re: Mach3 and Galil ... Getting better
« on: April 28, 2009, 11:41:14 AM »
The error that you are getting is normal when the MPG input axis is selected as an output axis in either the Tab-out screen or by a brain file. The error is just a notification that the input and output are currently configured to the same axis, and does not cause an operational problem. Try setting the controlled axis in the tabout screen to something other than the mpg input and everything should work OK. The error message will appear again if you are toggling through the controlled axes with the tab-out screen, when you get to the output axes that is specified for the MPG input. Disabling the MPG will make the message go away, but you will then have no MPG function. The MPG jumps over any mapped axes.
Kenny

Pages: « 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 »