Hello Guest it is August 09, 2022, 09:25:58 PM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - M250cnc

Pages: « 1 2 3 4 5 6 7 8 »
41
Works in progress / Lathe screen re worked
« on: September 23, 2009, 04:21:13 AM »
I am posting version 16 of my lathe screen.

It the standard lathe but with a more logical layout.

All the screens can be selected from any screen so no jumping backwards and forwards between pages.

The Home All Button now homes both axes, unnecessary buttons/duplicates removed.

It consists of the Default Page which is the Manual screen, Cycle screen, Tool adjust screen, & Diags screen.

Jogging is enabled on all screens but can be turned off via the jog button.

I use two Mpgs so i have added the controls on screen to adjust settings avoiding having to keep on bringing up the tab screen.

new in Version 16 i have added a led either side of the SINGLE LINE button, these flash so that you know what mode you are in.

Big thanks to Klaus for the excellent MachScreen that was used for the editing.


Phil

42
General Mach Discussion / Current list of G & M Codes for Lathe
« on: September 22, 2009, 07:02:29 AM »
Anyone know where i can get them, done a search but drew a blank

Phil

43
General Mach Discussion / Gcode/post processor help G77
« on: September 13, 2009, 06:13:35 PM »
I need help with the gcode generated with my cam program "OneCNC"

With a turn op Rough/Finish it generates the following code for G77

N240 G77 U2. R2.4
N250 G77 P260 Q360 U0.1 W0.1 F0.1

When this is dry run in Mach i only get the finish operation hence i haven't included that part of the code

If someone could help me figure out how to get this working i would be grateful

Thanks

44
PoKeys / Keyboard Disabled
« on: September 11, 2009, 05:00:02 PM »
OK at this stage everything seems to be working.

I have set up a hot key for the big red reset button and it works great.

But when i have focus on the MDI line this button no longer works.

Anyone have any clues, it seems strange as Mach is expecting keyboard input.

Thanks

45
SmoothStepper USB / USB Bandwith Problem & Solution
« on: September 09, 2009, 08:11:33 AM »
This relates to a laptop, i like to setup a bit at a time.

Once i enabled my network and plugged in my Pokeys the computer would crash this would only happen when i had the spindle running but not under gcode.

This was while i was still in the setup stages

I got round the crashed computer by inserting a switch to turn off the 5v supply to the SS this would allow the computer to regain control coming back with a message that the SS had lost communication.

I overcame the overall problem by adding a USB 2 PCMCIA card.

If you are using a desktop you may have the same problem with USB 1, so add a USB2 card

HTH helps someone save a bit of time.

Phil


46
General Mach Discussion / No jogging now
« on: September 09, 2009, 07:13:41 AM »
Hi i have been doing some screen designing "Standard Lathe Screen" and now the manual jogging has stopped working

I can use the jog toggle button to change to mpg and this will work with my mpg

I change screens and jogging works again

Any ideas ?

Phil

47
General Mach Discussion / Screen4 Help
« on: August 30, 2009, 07:15:24 PM »
I keep losing the ability to select the buttons/dros etc

I shift left click as per the video then it just stops working

This is the lathe screen

Any ideas ?

48
General Mach Discussion / Permanent Offset Error
« on: August 30, 2009, 06:24:01 AM »
Ok i am having difficulty with tool offset and now have got a new problem.

I appear to have a permanent offset.

I command a move to X0 Z0 the machine moves to X-0.7960 Z-0.3975 THIS IS DISPLAYED ON THE DRO'S.

I command a move to X120 Z80 the machine moves to X119.2040 Z79.6 THIS IS DISPLAYED ON THE DRO'S.

If i command the same move no move is made as as far as the controller is concerned the machine is at the correct location

I have attached my xml

49
General Mach Discussion / Maintenance Hours
« on: May 11, 2009, 03:35:56 AM »
Is there access to the Maintenance Hours boxes/Dro's

I tried a search through Hood's OEM list with no luck

Thanks
Phil

50
General Mach Discussion / Screenset installation
« on: May 04, 2009, 01:17:40 PM »
Hi all,

Yet another problem.

I have downloaded a screen set with the extension .m3s

When i double click it asks what program do i want to use to open it

Any clues

I did a search but nothing showed up

This is the one "Blue Screenset for Lathes"

Phil

Pages: « 1 2 3 4 5 6 7 8 »