Hello Guest it is May 09, 2021, 03:18:48 AM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Mr Sixx

Pages: 1
1
General Mach Discussion / Re: Limit switch issues
« on: November 10, 2019, 09:15:31 AM »
Not sure if I have the image correct but the z looks wrong  Z- should be below the home and as tweakie stated the Y axis looks reversed :)

2
what controller are you using? if its the HXC goto plugin control / Hxc Ncpod config and you have an option for homing pull off. It sets the distance for the duel stage homing and  also like you want the offset distance after homing. Hope this helps

3
General Mach Discussion / Re: mach3 download and setup
« on: November 10, 2019, 08:43:17 AM »
Hi Tanshi, thanks for the heads up. Just checked both are running 1903, My main pc like you stated has 16gb Ram but my laptop only has 4gb but all it has is google drive for gcode transfer from my main pc and mach3. Thanks again for the information hopefully it will stay as it is  ;D ;D

4
General Mach Discussion / Re: mach3 download and setup
« on: November 09, 2019, 12:47:39 PM »
Not sure this will help I am new to this myself I am using the whxc mach3 motion card (USB type B) £100. My apologies if its a Chinese clone my options where limited. Set up for software take 5min just drag and drop two files into the mach3 directory.

Works well on my main pc but in testing and for future use, it works well with a tablet/laptop both are running windows 10.

Not sure how long it will hold up through only had it a couple of weeks. Finished a couple of projects and it seems fine no bugs with the card (just my programming abilities) :-[

5
G-Code, CAD, and CAM discussions / Mach adding tool offset twice
« on: November 07, 2019, 01:19:05 PM »
Hi,
I am new to this, so I'm currently debugging my setup, The issue that has me stuck is that (drill2) works perfect but when (drill7) is active it adds the tool offset twice ie. offset set at 3.000 the dro would read 6.000. At the start, though it would be correct then jump to 6.000 causing the tool to crash

When drill7 goes to my safe z position for a tool change which I want it then move at my surface feed rate all the way down (which takes ages) until it reaches the clearance height than it's fine from there. Or is this normal for a drill op?

GCODE

(1001)
(T1  D=6. CR=0. TAPER=90DEG - ZMIN=-3. - SPOT DRILL)
(T2  D=7. CR=0. TAPER=118DEG - ZMIN=-12. - DRILL)
(T3  D=12. CR=0. - ZMIN=-7. - FLAT END MILL)
G90 G94 G91.1 G40 G49 G17
G21
G28 G91 Z0.
G90

(DRILL2)
M5
T1 M6
S1061 M3
G54
M8
G0 X-17.75 Y15.925
G43 Z5. H1
G98 G81 X-17.75 Y15.925 Z-3. R1. F10.
X-82.25
G80
Z5.
M9
G28 G91 Z0.
G90

(DRILL7)
M5
M1
T2 M6
S1000 M3
G54
G0 X-17.75 Y15.925
G43 Z15. H2
Z5.
G73 X-17.75 Y15.925 Z-12. R-7. Q0. F15.
X-82.25
G80
Z15.
G28 G91 Z0.
G90

(DRILL6)
M5
M1
T3 M6
S1000 M3
G54
M8
G0 X-17.75 Y15.925
G43 Z5. H3
G73 X-17.75 Y15.925 Z-7. R1. Q0.5 F10.
X-82.25
G80
Z5.

M9
G28 G91 Z0.
G90
G28 G91 X0. Y0.
G90
M30

Pages: 1