Hello Guest it is September 19, 2020, 06:17:58 PM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - MiguelAngel

Pages: 1
1
General Mach Discussion / Re: MDI and on-screen data do not match
« on: May 10, 2019, 01:51:29 PM »
Hello,
I have this laser https://lasertack.com/en/6w-445nm-engraving-and-cutting-laser-2
and I do not want to use arduino, I want to know why the data that is put in MDI do not coincide with what appears on the screen.
Thanks for your interest

2
General Mach Discussion / Re: MDI and on-screen data do not match
« on: May 10, 2019, 10:49:23 AM »
Sorry if it was not clear, I redraft it, thanks for being interested.
Hi all.
My name is Miguel Angel Amoros, I'm from Valencia, Spain.
I have a milling machine and a diode laser working perfectly with mach3.
To put the laser tube into operation, I looked for a lot of information on the internet, and until I found the posts Tweakie published on various forums, artsot, Hungarian, and others, I could not get the laser to work perfectly, in the end I did it work with the M11P system plus the virtual axis B, and now works great.
I have also been able to take pictures with the Impact / engrave Plugin that work well, but I have built the hardware with MAX digital potentiometer to be able to buy the Picengrave program, but this is where the problem comes from, I have done tests (with demo mode) and finish the photos burning excessively, and when the laser stops instead of going out, it stays burning a lot in the 0-0-0.
Investigating I realized that the problem is that the MAX goes out of range and sends too much tension to the laser, I realized when the gcode finishes that it stayed with almost three volts when it had to be at 0v.
Then I realized that there is a problem in mach3 when it is in millimeters, I have configured the Z axis as they say in picengrave that is that the Z axis has to have 393.7 steps per millimeter, and it turns out that if I reset the MAX , putting in MDI G0 Z-0.3238 which is 50% value to calibrate the MAX on the screen I get Z-3226. obviously in normal jobs this does not matter, but to calibrate the MAX and its subsequent conversion of pulses to volts is a big disaster.
This I have not been able to ask in picengrave because I asked to enter the forum, but surely if you do not buy the software they will not let you enter. But of course, if this can not be corrected, I will not buy the software.
Why do I put a figure in MDI and another one appears on the screen?

3
General Mach Discussion / MDI and on-screen data do not match
« on: May 09, 2019, 11:01:27 AM »
Hello, my name is Miguel Angel Amorós, and I want to ask you a question.
I have mach3 and it is working perfectly with milling and laser, I use the M11P system with a virtual axis "B" and it is a marvel.
but I want to take pictures with the Picengrave program, I have already made the hardware with the digital potentiometer MAX, but there is a problem that keeps me from buying the program, and I can not consult it in the picengrave forum because it seems that if you do not buy you can not enter .
I work in millimeters, I have 200 step motors, direct ball screw with pitch of 5 mm, and steps per pulse 320 and the problem is as follows:
in picengrave they say that I have to put on the Z axis 393.7 steps per millimeter, fine, but to calibrate the digital potentiometer I have to put in MDI G0 Z-0.3238, and Z-0.3226 appears on the screen, it seems a minor thing, but it causes the digital potentiometer to go out of range and then the photo burns.
Why does not the same figure appear on the screen when putting a figure in MDI?
and how can this be solved?

4
Hello, My name is Miguel Angel Amorós, I'm from Valencia, Spain.
I have a milling machine and laser moved by mach3 and I am happy, the machine was built by me, with 200 step motors (Chinese),
I've been reading forums for a long time and especially this, looking for the information needed to solve doubts, but today I need help because I can not find the solution to a problem that I will expose later.
Thank you all.

Pages: 1