Hello Guest it is September 26, 2020, 05:11:32 AM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - LilSpeedDemon88

Pages: 1
1
General Mach Discussion / Re: M30 not working in g-code
« on: April 12, 2018, 02:44:51 PM »
Alright, that worked! Thank you sir!

2
General Mach Discussion / M30 not working in g-code
« on: April 11, 2018, 04:33:44 PM »
Alright guys, so I'm having problems with my drill cycle programs not loading m30 on to the program run screen. Here is an example of the program I am using.

Ex:

G0 G49 G40  G17 G80 G50 G90
G20
S11000 M03
G54
G90
G00 G43 Z2.0

G98 G81 X 1.501   Y 5.195 Z-0.30  R.05 F10 P.5

X   1.501   Y   6.218
X   1.501   Y   7.478
X   2.013   Y   7.410
X   3.293   Y   7.410
X   6.692   Y   7.066
X   7.442   Y   7.436
X   8.192   Y   7.066
X   31.434   Y   7.552
X   49.941   Y   6.784
X   50.551   Y   7.493
X   51.161   Y   6.981
X   57.539   Y   6.981
X   58.149   Y   7.493
X   58.760   Y   6.784
X   60.517   Y   5.195
X   60.517   Y   6.218
X   60.517   Y   7.478
X   60.540   Y   12.301
X   60.540   Y   13.560
X   60.540   Y   14.584
X   58.782   Y   12.995
X   58.172   Y   12.286
X   57.562   Y   12.798
X   51.184   Y   12.798
X   50.574   Y   12.286
X   49.963   Y   12.995
X   31.457   Y   12.227
X   8.215   Y   12.713
X   7.465   Y   12.343
X   6.715   Y   12.713
X   3.315   Y   12.369
X   2.036   Y   12.369
X   1.524   Y   12.301
X   1.524   Y   13.560
X   1.524   Y   14.584
X   1.505   Y   18.452
X   1.505   Y   19.476
X   1.505   Y   20.735
X   2.297   Y   20.612
X   4.069   Y   20.612
X   56.136   Y   20.612
X   57.908   Y   20.612
X   58.700   Y   18.452
X   58.700   Y   19.476
X   58.700   Y   20.735
X   58.710   Y   25.558
X   58.710   Y   26.817
X   58.710   Y   27.841
X   58.198   Y   25.626
X   56.918   Y   25.626
X   3.306   Y   25.626
X   2.027   Y   25.626
X   1.515   Y   25.558
X   1.515   Y   26.817
X   1.515   Y   27.841

G80
M5 M9
F200
X70 Y0 Z2.
M30

So dumb question, but am I missing something as to why it wont rewind the program to the beginning? It ends the program just fine, but won't rewind. Another dumb question... Does Mach3 even allow M30 within the program, seeing that it has a rewind button? I would think so, but not totally sure as I'm not really familiar with Mach3. As soon as I load the program, M30 just disappears and it won't rewind.

Thanks in advance.

Pages: 1