Hello Guest it is December 09, 2021, 09:33:33 AM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - freshwatermodels

Pages: « 1 2 3 4 5 6 »
41
General Mach Discussion / Re: Mach3 condition abnormal light
« on: March 12, 2009, 03:10:31 PM »
Graham,

Exact Stop VS CV

The G code is fine, the problem is in Mach3.

Jack

42
General Mach Discussion / Mach3 condition abnormal light
« on: March 12, 2009, 01:59:29 PM »
I have two computers with Mach3 mill ver 3.00 .  The code below runs fine in Mach3 in one computer but not in the other.   In the computer set up on my mill I get a flashing "abnormal condition" light.  The code is fine.  What is causing this in Mach3???   

Jack


G00 G49 G40.1 G17 G80 G50 G90 G64
G20
(Standard Drill )
M6 T1
M03 S4583
G00 Z0.1250
X2.0000 Y0.2810
G81 X2.0000 Y0.2810 Z-0.6722 R0.1 F4.0
G80
G00 Z0.1250
G81 X0.5000 Y0.2810 Z-0.6722 R0.1 F4.0
G80
G00 Z0.1250
(2 1/2 Axis Pocketing)
M6 T2
M03 S4583
X1.2737 Y0.7375
G01 Z0.0292  F10.0
Z0.0042  F6.0
X1.2723 Y0.7383 Z0.0039  F4.0
X1.2656 Y0.7407 Z0.0026

43
Mecsoft (Rhinocam) called me and set up an on line meeting with both of us in control of my computer.  Truly a very painless way to deal with a problem!!!   The tech showed me the problem witht he post, explained it and solved the problem with the post. 

Mecsoft has proved their great support and great attitude.   One really finds out how good a software company is when dealing with problems!

Jack

44
What is XML?   How do I try anew XML?

Jack




45
How does this look?   Still abnormal condition.

G00 G49 G40.1 G17 G80 G50 G90G64
G20
(Standard Drill )
M6 T1
M03 S4583
G00 Z0.1250
X2.0000 Y0.2810
G81 X2.0000 Y0.2810 Z-0.6722 R0.1
G80
G00 Z0.1250
G81 X0.5000 Y0.2810 Z-0.6722 R0.1
G80
G00 Z0.1250
(2 1/2 Axis Pocketing)
M6 T2
M03 S4583
X1.2737 Y0.7375
G01 Z0.0292  F10.0
Z0.0042  F6.0
X1.2723 Y0.7383 Z0.0039  F4.0
X1.2656 Y0.7407 Z0.0026
X1.2588 Y0.7423 Z0.0014
X1.2518 Y0.7430 Z0.0001
X1.2447 Y0.7427 Z-0.0011
X1.2378 Y0.7416 Z-0.0023
X1.2310 Y0.7396 Z-0.0036
X1.2246 Y0.7368 Z-0.0048
X1.2185 Y0.7331 Z-0.0061
X1.2130 Y0.7287 Z-0.0073
X

46
Chip,

I edited the post by adding ther G64 as you said and got the following code which still sets off the abnormal light.   Maybe I'm doing something wrong?


%
N1 G40 G49 G80 G98
;Standard Drill
N2 G20 G90
N3 S4583 M03
N4 G00 Z0.125
N5 X2. Y0.281
N6 G81 X2. Y0.281 Z-0.6722 R0.1 F4.
N7 G80
N8 G00 Z0.125
N9 G81 X0.5 Y0.281 Z-0.6722 R0.1 F4.
N10 G80
N11 G00 Z0.125
;2 1/2 Axis Pocketing
N12 M00
N13 G20
N14 S4583 M03
N15 G90 X1.2737 Y0.7375
N16 Z0.125
N17 G01 Z0.0292 F10.
N18 Z0.0042 F6.
N19 X1.2723 Y0.7383 Z0.0039 F4.
N20 X1.2656 Y0.7407 Z0.0026
N21 X1.2588 Y0.7423 Z0.0014
N22 X1.2518 Y0.743 Z0.0001
N23 X1.2447 Y0.7427 Z-0.0011
N24 X1.2378 Y0.7416 Z-0.0023
N25 X1.231 Y0.7396 Z-0.0036

47
General Mach Discussion / Contacting Artsoft support by email?
« on: March 11, 2009, 01:20:31 PM »
I am having problems with Mach3 and am trying to resolve them .   Since it involves Rhinocam and Mach3 it's complicated to this newbie.   How can I contact someone  who is knowledgeable enough to help?    Can I contact someone who is part of Artsoft?   

Jack

48
General Mach Discussion / Re: Mach3 - Rhinocam2 PROBLEM
« on: March 11, 2009, 10:55:33 AM »
Hood,

Nope,  just inserting a G64 does not solve the problem.   I haven't a clue what to do.

Jack

49
General Mach Discussion / Re: Mach3 - Rhinocam2 PROBLEM
« on: March 04, 2009, 07:21:12 AM »
Hood,

Thanks for your reply!  I think you are correct in that the code doesn't revert to G64 constant velocity.   Maybe I did something wrong in Rhinocam2 or maybe it is just the way the post works.

Here is the code that Rhinocam2 generated:

G00 G49 G40.1 G17 G80 G50 G90
G20
(Standard Drill )
M6 T1
M03 S4583
G00 Z0.1250
X0.5000 Y0.2810
G81 X0.5000 Y0.2810 Z-0.6 R0.1
G80
G00 Z0.1250
G81 X2.0000 Y0.2810 Z-0.6 R0.1
G80
G00 Z0.1250
(2 1/2 Axis Profiling)
M6 T2
M03 S2000
Z0.0935
X1.5875 Y0.6880
G01 Z-0.1000  F20.0
X1.5833 Y0.7408  F6.0
X1.5710 Y0.7923
X1.5507 Y0.8412
X1.5230 Y0.8864
X1.4886 Y0.9266
X1.4484 Y0.9610
X1.4032 Y0.9887
X1.3543 Y1.0090
X1.3028 Y1.0213
X1.2500 Y1.0255
X1.1972 Y1.0213
X1.1457 Y1.0090
X1.0968 Y0.9887
X1.0516 Y0.9610
X1.0114 Y0.9266

50
I have been happily using Rhinocam V1 and liking it. Ver 2 came out
and I just tried to use it and ended up with problems.

I was making a simple 2.5D part each time I tried to run the program
posted from Rhinocam2 Mach3 either gives me an abnormal warning light
with the cause being displayed as " Exact Stop vs CV Mode" or locks
up. I managed to get the one off part made but didn't like running
with a warning light on.

The warning light comes on when it reaches this line in the program

G81 X0.5000 Y0.2810 Z-0.6 R0.1

I'm pretty rank with both Rhinocam2 and Mach3. Until this they have
been pretty cookbook but....

Anyone have any ideas about this problem???

Jack



Pages: « 1 2 3 4 5 6 »