Hello Guest it is November 16, 2019, 09:38:52 PM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - mhickler

Pages: 1 2 »
1
Thanks! Worked like a charm.

2
I should have mentioned that I am using the milling application.

3
My computer died and I am setting up Mach 3 from scratch. When I home my motors they go away from the switches. Can I reverse them in setup somewhere? I did it two years ago, but now I forget how.

4
General Mach Discussion / G code for controlling axis 4
« on: October 25, 2007, 02:27:14 PM »
I'm using mach mill with X, Y, Z and 4 axes. I am controlling two cross slides. X and Y for cross slide one and Z and A for cross slide two. If I try a G code for axis 4 I get an error because "4" is read as a number.

Examples:
G1 X1 works
G1 41 doesn't work

Is there a syntax for handling an axis that is named with a number? Can I rename my axis without a lot of work?

5
Modbus / Variable speed controller with modbus communication for AC motor
« on: October 22, 2007, 05:39:10 AM »
I am creating a specialized lathe running four steppers on two cross slides.I have an AC motor turning the lathe spindle that is hooked up to a variable speed controller, specifically a GS2 from Automation Direct. According to the specifications, this unit has "RS-232/485 Modbus communications up to 38.4 Kbps." Can I somehow use this feature so I can controll the spindle speed (via the controller and AC motor) from Mach software?

6
General Mach Discussion / Re: Only X axis responds
« on: August 12, 2007, 05:03:52 PM »
Joy! Your last tip did it. I had transposed the numbers. Thanks VERY much!

7
General Mach Discussion / Re: Only X axis responds
« on: August 12, 2007, 05:01:31 PM »
I found my documentation and found the proper pin settings. Now only X works with X commands. Others are motionless.

8
General Mach Discussion / Re: Only X axis responds
« on: August 12, 2007, 04:49:21 PM »
Yes, to both responses. I had a feeling that it was ports and pins. All are set to 3 for Step and 2 for Direction. Do both change for each axis? Are there any likely recipes? I'm waiting to hear back from my controller maker. He may have the solution. Thanks so much for the help so far.

9
General Mach Discussion / Only X axis responds
« on: August 12, 2007, 01:21:56 PM »
I am new to CNC. I bought a controller and motors from a reputable dealer. I hooked it up to the computer to see if I could make the motors turn as a first step. All commands sent to X and Y motors are executed by the X motor. How can I test or troubleshoot my connection to the other motors? Thanks!

10
I am developing a lathe with two cross slides. Each cross slide has two axes. Go to www.hicklerbanjo.com to see earlier prototypes. I have been reading Mach 3 turn documentation and discovered that, in theory, you can hove more than three axes. I found that you can configure motor outputs and was hoping that is the place to configure new or non-default axes. I went to config: ports and pins: motor outputs. I enabled X, Y, A and B. I was hoping to use X and Y for one cross slide and A and B for the other cross slide. I clicked OK to save my motor output configuration. When I returned to the main window I only saw the default X and Z axes listed. Restarting the program did not help. I reopened the configuration screen and my motor output selections were still there.

I should probably mention that at this point I am awaiting a 4-axis controller and motors I had ordered. I am trying to get some knowledge of the software before the hardware arrives. If anyone in the community has ideas for this unusual configuration, I would appreciate it!

Pages: 1 2 »