Hello Guest it is August 10, 2022, 12:25:15 AM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Pedio

Pages: « 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 »
161
Mach4 General Discussion / Re: Mach 4 Tool Auto Zero
« on: July 28, 2015, 05:08:49 PM »
Did you guys get this to work? I believe that the smartBob now has probing working. I can get the LEDs to change when my touch plate is touched to the bit.

Also, not sure how to use G-code in the Lua interface. Do I just enter it where the script goes? Will this reset my Z=0 for the machine or only set a difference for the one run of the current file? Anyone have a script that works. This would make my life compete (until I hit the next challenge).   ;D

162
Mach4 General Discussion / Re: Shuttle Pro Plugin!!!!
« on: July 26, 2015, 04:44:32 PM »
BTW - keyboard jogging now seems to be working! Go Mach development team - go.

163
Mach4 General Discussion / Re: Shuttle Pro Plugin!!!!
« on: July 26, 2015, 04:37:41 PM »
I figured it out - I had programed a couple of example keystrokes into the shuttle pro using its native control panel. The shuttlepro was seeing both the plugin commands as well as the keystroke commands. I took the commands out of the control panel and everything works! This has made my day!

164
Mach4 General Discussion / Re: Shuttle Pro Plugin!!!!
« on: July 26, 2015, 04:31:30 PM »
Got homing on X and Y axis to work and the shuttle pro works for that.

165
Mach4 General Discussion / Re: Shuttle Pro Plugin!!!!
« on: July 26, 2015, 04:30:35 PM »
its only for testing it one of the things they are working on so bugs will be there post in the yahoo form if you are a member

I tried joining the other day but I have not checked to see if it was successful. It was Mach1Mach2Mach3... or something like that. I will look again when I get to my other computer that has my password etc. Feel free to repost the bugs if you are on that site. I would love to have a shuttle pro that worked! Right now the center wheel slow .01" jog is a dream. I can set the Z from in front of the machine!

Now to get tool height setting to work...

166
Mach4 General Discussion / Re: Shuttle Pro Plugin!!!!
« on: July 26, 2015, 10:31:40 AM »
I was mistaken - the slow speed jog using the larger jog wheel appears to move multiple axis at the same time. I will play with it a little and let you know if I find anything.

167
Mach4 General Discussion / Shuttle Pro Plugin!!!!
« on: July 26, 2015, 10:28:59 AM »
I don't know if anyone noticed but there is a shuttle pro plug in in the latest release of Mach4 (#2580) - Yeaaaaaaaa.

I have found the following:

   The Mach4 window does not have to have focus for the ShuttlePro to work! Yea

   The larger jog wheel on the middle of the Shuttle Pro is preset to Jog slow to fast depending on how far the wheel is turned. Good way of doing this.
       Warning - On my machine the slow speeds appear to jog the X axis along with any selected axis when Mach 4 first starts; e.g., if I select Y axis the large jog wheel will move the X and Y axis. If I move the center Jog wheel the outer jog wheel behaves as expected for the rest of the session. (I have a gantry style machine with slaved X axis running SmartBob from PMDX so it may work on your machine)

   The center jog wheel moves the selected axis at a very slow speed (THIS IS NICE!!!)

   The Jog rate + and - seem to jog my Z axis instead of changing the jog rate

   There dose not appear to be any selection for Jog X / Y / Z axis + / - right now. The way I previously set up my shuttle pro is to allow different buttons to jog different axis; e.g., the buttons to the left and right of the jog wheel move the Y axis, the two buttons below and to the right of the jog wheel move the Z axis, and the jog wheel moved the X axis in my previous set up. The wheel in the middle of the jog wheel changed the rate of speed of the jog in my previous set up.
   
   The zero axis, cycle start, cycle stop all seem to work. I can't test the Homing function since the latest version of SmartBob homing of X / Y is not working (Z works). If someone else can test this and let us know if it works I would appreciate it.

   The plugin will work with other buttons assigned through the Shuttle Pro programing interface. If you want to do normal windows stuff with some of your buttons and Mach 4 stuff with others it is possible. I am not sure which will override the other so be careful in programing the buttons through the normal ShuttlePro interface. I use one of the buttons on the ShuttlePro to move the Mach4 screen from the control computer to the touch screen that is adjacent to the CNC machine.

All in all this seems to be a very nice addition to Mach4 and will definitely make my machine more usable - thanks for the enhancement.




168
Mach4 General Discussion / Re: Mach 4 Bug Reports
« on: July 23, 2015, 02:03:01 PM »
Not sure if this has been reported but occasionally the display showing the tool paths that have been run by the machine does not line up with the toolpaths on the display.

169
Mach4 General Discussion / Re: Mach 4 Feature Request
« on: July 21, 2015, 04:54:24 PM »
Can we get a menu item or something under the load screen set menu item that allows someone to see what screen set they are currently using?

Thanks,
Peter

170
Mach4 General Discussion / Re: external cycle start
« on: July 17, 2015, 02:22:12 PM »
Works - yeaaaaaa. I had to map my Input B on smartBob to input 1 on Mach4.

Dose this script also allow me to program a feed hold on Input 6?

Thanks,
Peter

Yep - the Pause or Feedhold works on Input 6.

Pages: « 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 »