Hello Guest it is December 01, 2021, 04:45:30 AM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - xtjoliverx

Pages: « 1 2 3 4
31
Tangent Corner / Re: Mach users in your area
« on: February 28, 2015, 01:18:18 PM »
This is a good idea. Most of the othwr forums that I am a member of (non-cnc) have something like this. One even has a map with a dot for everyone that input there location.

I live in Lebanon, Pa and would love to be able to talk and hangout with others interested in the CNC world.

32
Nevermind my cries for help. I got it working. Turns out that longs motor has exact directions on interfacing their breakout boards with Mach 3. The online chat support person had screenshots of all of the config settings. Now that my mind is at ease (for now) I will soon make a thread in the show and tell of my progress so far. Just to let everyone know, I have the longs motor 4 axis nema 34 1232 oz in. kit. So if anyone is interested I can list my exact details to make setting up your hardware with mach 3 much easier.

33
Ok, I think I have an update. I was messing with the port address, and have noticed that if i try the addresses in between the ones listed in the the resources tab of the device manger, that I can get different light combinations to light up in the diagnostics screen under the port 1 pins current state. But, the most I could ever get to light up at once was the first 7 of the top row and nothing on the bottom row. And this happened on any of the second numbers.

Here is what my device manger lists:

Multifunction Adapters
   PCI Mullti-IO Controller
I/O Range 9C00-9C07
I/O Range 9800-9807
I/O Range 9400-9407
I/O Range 9000-9007
I/O Range 8C00-8C07
I/O Range 8800-880F

Ports (COM & LPT)
   PCI Parallel Port (LPT2)
       Use any interupt assigned to the port (CHECK)
       Enable legacy plug and play detection(CHECK)
I/O Range 9C00-9C07
I/O Range 9800-9807
IRQ 16
   PCI Parallel Port (LPT3)
       Use any interupt assigned to the port (CHECK)
       Enable legacy plug and play detection(CHECK)
I/O Range 9400-9407
I/O Range 9000-9007
IRQ 16

Now that I have listed that, it might be easier to explain what I meant. Any of the second numbers ie 0x9407 gives me the first seven pins of the Port 1 current state. And this is the same for all of the second numbers. Anyone have any ideas?

 

34
Thanks a lot and I will definitely check that out. But, right now I am spending all of my free time trying to get my current setup working. I will post my xml file and hopefully someone would be kind enough to take a look at it for me. I would greatly appreciate it. I have scoured this forum and tried every solution I could find on here, with no luck. Ill try to give as much info as I can:

Windows XP Pro 32bit fresh install fully updated
Addon Rosewill dual PP card rc-304
LPT2 0x9400 Only using port 1, and verified the port in ports and pins
x axis enabled pins 2 and 3, port 1
jog is on
I have the following green port lights on the diagnostics screen: three off five on and the bottom row is completely off

I am completely stumped.

35
I am only just beginning to get into the cnc scene. But, from what I gather about Mach 3 is that it is very feature rich for the price but it is picky. And, with me just getting into the hobby, Id like to stick to tried and true methods. Its only a cnc plasma table. I dont need top notch, nor all the bells and whistles. But, then again this is my first machine. Do you have a good resource for this ethernet smooth stepper topic, where I could read up on it? After all the trouble I just went through with Windows XP and the first parallel card Its sounds like a definate possibility in the future.

36
Hello all, I ordered the rosewill card mentioned in this thread and it is on the way. I see this thread is a couple years old and the drivers mentioned were released in 2010. Has anyone used the newer drivers on the moschip website successfully? Im hoping they work because I cant seem to find the older drivers anywhere. Do any of you have a backup copy saved anywhere? Thanks in advance for any help anyone might be able to provide.

Pages: « 1 2 3 4