Hello Guest it is December 08, 2019, 11:33:45 PM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - PtD

Pages: 1
1
Modbus / TCP Modbus doesn't refresh holding registers?
« on: January 05, 2017, 04:58:18 PM »
Hi,

I have set up an Arduino as TCP Modbus slave, and I have programmed it to increase the value of the holding registers every 2 seconds. I can connect to it just fine, I get the registers read and all seems perfect... Except that Mach3 only reads the up-to-date value of the holding registers only when I press "Apply" in the "Setup TCP Modbus" dialog. I have a brain that writes these values in user DROs, and the DROs have the values from the moment of pressing "Apply", they never change, unless I open the setup dialog and press "Apply" again.

In the TCP Modbus test dialog the values are updated every time when I press "Read".

Is this the expected behavior, or I'm missing something?

Mach3 version is R3.043.066, I am a licensed user. Configuration screens are attached below.

Thanks in advance.

2
General Mach Discussion / Re: G31 causes an endless loop
« on: November 02, 2014, 06:25:27 PM »
Follow up: This VB code works fine:

Code: [Select]
For y = 0 To 10
For x = 0 To 10
Code "G0 Z1"
Code "G0 X" & x & "Y" & y
While IsMoving()
Sleep(10)
Wend

Code "G31 Z-10"
While IsMoving()
Sleep(10)
Wend
Sleep(10)
zProbe = GetDRO(2)

Message "x " & x & ", y " & y & ", z " & zProbe
Next
Next

It seems that the problem is related to timing issues. If I omit the sleep(10) before the GetDRO(2) call, I get spurious values for Z.

Based on this VB script, I developed a wizard that does the whole digitizing in VB. I will keep trying to resolve the issue in G-Code.

Thanks for your support.

3
General Mach Discussion / Re: G31 causes an endless loop
« on: November 01, 2014, 12:42:17 PM »
Right. The controller is YooCNC USB motion card (the one from X6-1500GT). What I see is that G31 is correctly executed - it touches probe and then program moves to another step. What could be the reason that G31 command (executed with whatever controller) is making Mach3 go back a line?

4
General Mach Discussion / Re: G31 causes an endless loop
« on: October 31, 2014, 04:44:18 PM »
I confirm the same behavior both in licensed and demo mode.

I would suspect some quirks with the controller, but I can't see how the controller can cause a step back in the execution order in Mach3...

5
General Mach Discussion / Re: G31 causes an endless loop
« on: October 31, 2014, 07:42:11 AM »
Installed R3.042.020 on another machine - that never had Mach3 before. Configured motors and inputs. Same endless loop.

Is there a debug mode I can turn on so that I can report more information for troubleshooting?

6
General Mach Discussion / Re: G31 causes an endless loop
« on: October 31, 2014, 07:24:46 AM »
I installed R3.042.020. Changed the default configuration just for input signals and motors. Ran the Digitize.tap. Same result - loops over and over between G31 and G0.  :o


7
General Mach Discussion / Re: G31 causes an endless loop
« on: October 30, 2014, 02:51:14 PM »
Here it is, attached to the post.

Also can be read at https://www.dropbox.com/s/nijslczuy3apqsv/Mach3Mill.xml?dl=0

And here is a video of the loop sequence I shot: https://www.dropbox.com/s/844htm1iilp2wum/MOV_0761.mp4?dl=0

Thanks in advance for your support!

8
General Mach Discussion / Re: G31 causes an endless loop
« on: October 30, 2014, 01:59:19 PM »
You are correct that this is not the exact code from the Digitizing Wizard. It is a simplified version just to expose the loop. Here is the actual Digitizing Wizard code:

 (Digitize File)
M40
G92X0Y0Z0
F100
 G0X0Y0Z1
 G31 Z-10
 G0 Z1
 G0X1Y0Z1
 G31 Z-10
 G0 Z1
 G0X2Y0Z1
 G31 Z-10
 G0 Z1
 G0X3Y0Z1
 G31 Z-10
 G0 Z1
....

Here the loop happens on lines 5 and 6:
 G0X0Y0Z1
 G31 Z-10

In the "Current Line Number" DRO it goes 5, 6, 5, 6, 5, 6... ad infinitum. The strange thing is that once or twice, with other parameters for height and depth it worked, but I can't reproduce them.

Mach3 version is R3.043.066.

9
General Mach Discussion / G31 causes an endless loop
« on: October 30, 2014, 04:09:47 AM »
Hi all,

I am using Digitizing Wizard to extract a 3D model from an object, and I've encountered the following problem: when executing this G-Code sequence

N1 F100
N2 G0X0Y0Z1
N3 G31 Z-10
N4 G0 Z1
N5 G0X1Y0Z1
N6 G31 Z1
N7 G0 Z10
N8 G0X2Y0Z1
...

Mach3 starts looping between lines 2 and 3. It would position at (0,0,1) @ line 2 , then it would probe down to touch the object @ line 3, and then for some reason it returns to execute line 2 again, instead of moving forward to line 4.

I suspected it may have something to do with Safe Z, but it doesn't work with any setup of Safe Z I tried.

What can be the cause of this odd behavior?

(Sorry if this has been answered before).

Thanks in advance.

Pages: 1