Hello Guest it is January 27, 2023, 10:27:50 AM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - cncbobuk

Pages: « 1 2 3 4 5 6 »
41
General Mach Discussion / Re: Homing Slaved Axis Y(A)
« on: January 13, 2015, 11:59:57 AM »
IF you are going to Home slaved axis (YA) then you need to use RefCombination() to do the slaved axis  (YA).

Just a thought, (;-)

I've seen this referenced before, sorry to be thick but what do you you mean? do I put !RefCombination()" somewhere in the button script, if so exactly where? What should my script look like?

Many thanks,

Bob.

42
General Mach Discussion / Re: Homing Slaved Axis Y(A)
« on: January 13, 2015, 11:24:16 AM »
Ok thanks for the info, that's another dead end then as it's a Chinese board and getting any help on it is next to impossible. I had assumed that as all the inputs work as expected it would be ok. interestingly if I use just one home swicth and simply slave the Y and A motors it works fine>?????

43
General Mach Discussion / Re: Homing Slaved Axis Y(A)
« on: January 13, 2015, 07:13:32 AM »
Here goes..........

44
General Mach Discussion / Re: Homing Slaved Axis Y(A)
« on: January 13, 2015, 06:05:20 AM »
Sorry about this but I don't seem to be able to upload the file, all I get is an error message,

"Sorry! There is already an attachment with the same filename as the one you tried to upload. Please rename the file and try again."

What am I doing wrong?

45
General Mach Discussion / Re: Homing Slaved Axis Y(A)
« on: January 13, 2015, 05:43:35 AM »
Many thanks, all switches behave correctly on the diagnostics screen.

Attached xml as requested, hope this helps.

Your help is much appreciated,

Bob.

46
General Mach Discussion / Re: Homing Slaved Axis Y(A)
« on: January 13, 2015, 03:32:21 AM »
Tried that, if I check this the Y motor runs on it's own the A motor doesn't run at all.

47
General Mach Discussion / Homing Slaved Axis Y(A)
« on: January 12, 2015, 08:51:28 AM »
Sorry about this I know this has been covered before but I've done a lot of searching round on here for the answer but can't get to the solution to my problem.

My machine has a gantry driven by 2 steppers (Y axis, A slave) I have 2 home switches connected to their own inputs. When I hit "Ref all home" Z axis refs ok, X axis refs ok then Y begins to travel towards the switch. If I operate the Y axis switch nothing happens, the Y motor continues in the same direction, if I operate the A switch the A axis motor reverses then stops after coming off the switch but the Y axis motor continues. Nothing I do will stop the Y motor other than an emergency stop. I have checked the diagnostic screen and all switches operate as expected. What am I missing?

My button script is as follows,
DoOEMButton (24) 'ref Z
DoOEMButton (22) 'ref X
DoOEMButton (23) 'ref Y
DoOEMButton (25) 'ref A


DoOEMButton (133)
DoOEMButton (134)
DoOEMButton (135)

Many thanks,

Bob.

48
General Mach Discussion / Re: Start/Stop cycle button?
« on: November 13, 2014, 03:09:01 PM »
Thanks Hood, I had assumed it must be fairly simple. Is there a list of OEM codes available somewhere or a way of determining them? as there a few other things I'd like to implement.

Cheers.

49
General Mach Discussion / Start/Stop cycle button?
« on: November 13, 2014, 12:37:22 PM »
I'm sure this has been asked before but can't find any reference to it so, can I connect push buttons to Mach 3 inputs and have them perform program start and stop/pause?

I'm guessing something to do with "system hotkeys" but need some help here please.

Many thanks.

50
General Mach Discussion / Re: DDUM5 Breakout Board and fake licence
« on: October 17, 2014, 02:39:56 PM »
Update.

It looks very much like the makers of the DDUM5 board have also modified the version of Mach 3 they are bundling with the board. A quote from their own web-site

 "support software —MACH3 softwareV3.0 higher version;now dont support all kinds of mach3 of Chinese edition correction and  its  derivative software interface way–mach3 software interface by DDUM.DLL (dynamic linking libraryinterface )."

I think this is saying it only works with their modified version of Mach 3.

It's a shame as this board could otherwise be a brilliant solution. Can I suggest a warning be posted somewhere to the effect that this board is not what it appears to be. Don't waste your money on it.

For me it's going in the bin and now looking for a suitable replacement.

Pages: « 1 2 3 4 5 6 »