Hello Guest it is February 21, 2024, 11:47:53 PM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - PW8697

Pages: « 1 2 3 4 5 6 »
21
General Mach Discussion / Re: Backlash when enabled, kills everything.
« on: October 26, 2015, 07:42:08 PM »
Roger, don't know what those numbers in Step pulse and Direction Pulse do in the motor tuning window.  Mill has been running fine all along, so signals are getting to where they need to.  Except with backlash compensation enabled, at least on this interface board.  

Pete

22
General Mach Discussion / Re: Backlash when enabled, kills everything.
« on: October 26, 2015, 02:39:48 PM »

Just found out something interesting.  I have two laser systems, both use the Xulifeng-Mach3-USB-Motion-Card.  They work fine with Backlash Compensation enabled or not.  So, it has boiled down to the MK3 interface board and/or its drivers.  I have contacted the company to see if there are updated drivers for the board.  Otherwise I will get another Xulifeng board for my mill, as the other two are totally bulletproof and have had no problems with them at all. 

Will keep you posted on what happens. 

Pete

23
General Mach Discussion / Re: Backlash when enabled, kills everything.
« on: October 26, 2015, 02:00:33 PM »
Roger,

Just did a complete new install of V.062.  Did a complete uninstall to include deleting the Mach3 folder from C:.  Installed V.062, copied over the .xml files to the Mach3 folder and the plugins as well.  Mill works as it did before.  BUT again, as before with V.064, the backlash enable kills the motors.  Deselect the checkbox and again the mill will work. 

Frustrating issue for sure.

Pete

24
General Mach Discussion / Re: Backlash when enabled, kills everything.
« on: October 26, 2015, 12:00:46 PM »
Chaoticone,

Step and Direction are both 0 on each axis. 

Pete

25
General Mach Discussion / Re: Backlash when enabled, kills everything.
« on: October 25, 2015, 04:50:23 PM »
Roger,

I've downloaded V.062 and will install and try tomorrow. 

As far as the DRO change and move stepper movement, I thought power supply first as well, but as soon as I deselected the enable backlash checkbox and restarted Mach3, the motors worked fine. 
Select the checkbox and the motors won't work. 

All in all, I hope the earlier version will help.  And maybe cure some of the persistent bugs I have.

Pete 

26
General Mach Discussion / Re: Backlash when enabled, kills everything.
« on: October 25, 2015, 09:15:49 AM »
Ok Roger, I'll try that for sure.  Maybe doing that will also clear up a multitude of other bugs.

What about the other settings and whatnot I posted here?  Am I correct in what I did? 

Pete

27
General Mach Discussion / Re: Backlash when enabled, kills everything.
« on: October 24, 2015, 04:09:07 PM »
Also,

All in all, I am not sure if CV mode is even necessary for the backlash compensation to work.  I was just following along with a post on CNCzone, and also the Mach3_CVSettings .pdf I stumbled upon.  But is seems, like with Hoss's youtube video, it is simply a process of filling in the backlash window parameters and that's it. 

BTW, running latest version of mach3, 066. 

Pete

28
General Mach Discussion / Backlash when enabled, kills everything.
« on: October 24, 2015, 03:07:58 PM »
Hello all.  I've been noticing some egg-ish pockets when they are supposed to be round.  I have a Taig mill and am wanting to apply backlash compensation.  Following bits and pieces on various posts here and there have been doing the following steps. 

Going into General Config and deselecting CV Dist Tolerances and Stop CV on Angles.  Then Selected CV instead of Exact Stop and then set shuttle Accel. speed to .05.  Click OK and then Config>save settings. 

Then go into Config>backlash.  Input for X .0012 and Y .0035, set backlash comp speed to 50% and then enable>OK then close out of Mach 3 and restart.

After restart, I got back to General Settings and set CV Distance tolerance to 180 (was the default amount) and set Stop CV on angles >90 (will need to see how the values effect things).  Then OK and then Config> save settings. 

After doing all that, no axis will move.  The DRO will change but there is no movement of any of the 3 steppers. 

Ill keep hunting for clearing directions on setting this up, in the meantime I would greatly appreciate any help.

Thanks, Pete

29
VB and the development of wizards / Re: Auto Tool Zero Keyboard shortcut
« on: September 14, 2015, 09:46:37 AM »
Using a roller ball mouse, lot faster and accurate with less hand movement needed, plus the buttons are larger.  Will try MachScreen in the near future though. 

30
VB and the development of wizards / Re: Auto Tool Zero Keyboard shortcut
« on: September 01, 2015, 04:00:32 PM »
Joypad?  Don't want to add more hardware, cables, connections, failure points, etc.

Pages: « 1 2 3 4 5 6 »